Школа-гимназия №1 имени Динмухамеда Конаева
ОТКРЫТЫЙ УРОК в 7 гр классе Тема: Двумерный массив. Основные понятия. Методическая цель: Развитие творческой деятельности на уроке информатики. Арынова А.Ч. учитель информатики
Класс 7гр Дата 04.01.15г.
Тема: Двумерный массив. Основные понятия.
Цель: Получить общее представление о двумерном массиве и способе его формирования.
Развивать логику мышления, умения и навыки в программировании простых задач, познавательный интерес, навыки работы на компьютере, самоконтроль, умения конспектировать
Воспитывать информационную культуру учащихся, внимательность, аккуратность, дисциплинированность, усидчивость
Знать: Понятие двумерный массив, размерность, индекс, описание массива, ввод и вывод массива.
Уметь: Формировать массив, решать задачи на обработку массива.
Оборудование: ПК, прг.Паскаль АВС, флипчарты, маркеры, тестирующая программа Мультитестер.
Ход урока
| Этапы | Деятельность учителя | Деятельность учащихся |
| Приветствует учащихся
| Приветствуют друг друга |
2 минуты | Разминка
| Учащиеся изображают мимикой и жестами все действия. |
1 минута | Предлагает взять по листочку, найти свои половинки и объединиться в группы. На листочках типы элементов: real, integer. Просит объяснить, по каким принципам разделились на группы. | Берут по листочку, ищут свои половинки, объединяются в группы. Объясняют по каким принципам нашли свои группы. |
5 минут | Предлагает внимательно послушать сказку, на основе которой нужно составить программу на одномерный массив на флипчартах. Текст сказки. Среди небесных созвездий и множества планет во вселенной существует маленькая планета под названием Программус. Территория этой планеты была постоянной и равнялась 10 звездным километрам и считалась настолько прямой, что все дома жителей этой страны были построены в один ряд, а самих жителей звали элементусами. Правил всеми элементусами массивный царь по имени «Аус». Служили царю верою и правдою его подчиненные Индексус и Размерус. Жизнь на этой планете была всецелой, ровной и прямолинейной. Но однажды случилось горе, владыка других планет Вириус объявил войну планете Ауса. Погоревал царь Аус, не любил он войны и решил издать указ: «Срочно собрать всех элементусов планеты и приготовиться к наступлению». Верные слуги царя Индексус и Размерус решили собрать всех элементусов планеты. Так и сделали: собрали всех от первого до последнего элементуса, дали каждому по номеру, чтобы был учет и порядок и вывели к царю на показ. Увидел их царь и покачал головой. Ох как было их мало? Посоветовавшись царь со своими слугами решил просить помощи у брата двумерного массивного царя. | Каждая группа внимательно слушает и составляет программу на флипчартах. |
6 минут | Предлагает защитить работы. Вопросы группам.
| Рассказывают о программе: Отвечают на вопросы.
Вывели элементы
|
5 минут | Предлагает самостоятельно изучить теоретический материал по презентации. | Изучают конспектируют |
| Переход на новую тему. 5 минут |
Использует карточки для объяснения. | Слушают и конспектируют в тетрадь. |
10 минут
| Предлагает проверить программу вывода элементов двумерного массива на экран. Можно оказать помощь учащимся из своей группы.
Вывод элементов одномерного массива на экран:
Рrogram vivodmassv1; const nn = 10; var a: array[1..nn]of integer; i, n: integer;
begin writeln('razmer'); readln(n); for i := 1 to n do
begin writeln('element'); readln(a[i]); end;
for i := 1 to n do
write(a[i]:3); writeln;
Набор и отладка программы. | Работают индивидуально Делают отладку программы Исправляют ошибки. Вывод элементов двумерного массива на экран.
Рrogram vivodmassv2; const nn = 10; const mm = 10; var a: array[1..nn, 1..mm]of integer; i, j, n, m: integer;
begin writeln('razmer'); readln(n, m); for i := 1 to n do for j := 1 to m do
begin writeln('element'); readln(a[i, j]); end;
for i := 1 to n do begin for j := 1 to m do write(a[i, j]:3); writeln; end; end.
|
5 минут | Предлагает проверить знание на теорию, ответив на тестовые вопросы на компьютере. | Тестируются с помощью программы мультитестер. Выписывают свои оценки в тетрадь. |
| Предлагает озвучить оценки за тесты. | Озвучивают свои оценки |
2 минуты
| Предлагает подвести итог урока
| Отвечают на вопросы. |
1 минута | Выберите фразеологизм или пословицу которые характеризуют вашу работу сегодня
| Выбирают фразы и характеризуют свою работу |
Видеоролик «Танцоры» 2 минуты
|
| Записывают домашнее задание в дневник |
|
| БЛАГОДАРИТ ЗА УРОК
|
|



Разработка урока на тему: Двумерный массив. (17.02 MB)

