Практическая работа 5
Тема: Программирование циклических алгоритмов с условием окончания работы
Задание:
-
Задание 1.
-
Выполните Задание 1 в среде ABС Pascal. NET
-
Сохраните результат в своей папке.
-
Покажите результат работы программы учителю.
-
-
Задание 2.
-
Выполните Задание 2 по своему варианту (номер в журнале).
-
Оформите отчет по шаблону в файле
x:\8 класс\Отчет по практической работе паскаль.docx -
Покажите результат работы программы учителю.
-
-
Оценка “5” если выполнены два задания, оформлен отчет по Заданию 2
“4”- сдано Задание 1, отлажена программа Задание 2 без отчета;
“3” – выполнено только первое задание.
Задание 1
Составьте программу по образцу:
-
программа должна выводить на экран ФИ и класс учащегося.
-
программа должна выводить на экран задание.
-
Выполните программу в среде ABС Pascal.NET;
-
Исправьте ошибки;
-
Выполните программу для тестовых значений
Входные данные
Выходные данные
22
27.7
17.4
32.9
0
100
-
Введите значения.
-
Покажите результат учителю.
Образец:
program summa;
var
s, n; real;
begin
writeln (Программа расчёта суммы чисел, введённых пользователем.');
s:=0;
repeat
write ('Текущая сумма: ', s. Введите очередное слагаемое или 0 для выхода');
readln (n:2);
s:=s+n;
until n = 0;
write ('Итоговая сумма: ', s:4:1);
end.
Задание 2
Составить программу
-
программа должна выводить на экран ФИ и класс учащегося.
-
программа должна выводить на экран задание.
-
при разработке использовать цикл repeat … until
-
Значения числовой последовательности вводится с клавиатуры. В конце последовательности вводится 0.
-
Значение выводиться в формате на 5 позиций.
-
Напишите программу, которая в последовательности целых чисел определяет количество нечётных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести: количество нечётных чисел, кратных 3.
Пример работы программы:
Входные данные | Выходные данные |
3 | 2 |
-
Напишите программу, которая в последовательности целых чисел, кратных 5, и определяет их сумму. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести: сумму чисел, кратных 5.
Пример работы программы:
Входные данные | Выходные данные |
4 | 79 |
-
Напишите программу, которая в последовательности целых чисел определяет количество чётных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести сумму чётных чисел.
Пример работы программы:
Входные данные | Выходные данные |
4 | 2 |
-
Напишите программу, которая в последовательности целых чисел определяет количество положительных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести количество положительных чисел.
Пример работы программы:
Входные данные | Выходные данные |
−20 | 3 |
-
Напишите программу, которая в последовательности целых чисел определяет количество, кратных 5. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести: количество чисел, кратных 5.
Пример работы программы:
Входные данные | Выходные данные |
4 | 2 |
-
Напишите программу, которая в последовательности целых чисел определяет сумму чисел, кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести: сумму чисел, кратных 3.
Пример работы программы:
Входные данные | Выходные данные |
3 | 204 |
-
Напишите программу, которая в последовательности целых чисел определяет сумму чётных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести: сумму чётных чисел.
Пример работы программы:
Входные данные | Выходные данные |
4 | 64 |
-
Напишите программу, которая в последовательности целых чисел определяет их сумму отрицательных чисел последовательности. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести сумму отрицательных чисел.
Пример работы программы:
Входные данные | Выходные данные |
150 | -201 |
-
Напишите программу, которая в последовательности целых чисел определяет сумму положительных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести сумму положительных чисел.
Пример работы программы:
Входные данные | Выходные данные |
−20 | 1106 |
-
Напишите программу, которая в последовательности целых чисел определяет сумму, кратных 5. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести: сумму чисел, кратных 5.
Пример работы программы:
Входные данные | Выходные данные |
4 | 75 |
-
Напишите программу, которая в последовательности целых чисел определяет их количество отрицательных чисел последовательности. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести количество отрицательных чисел.
Пример работы программы:
Входные данные | Выходные данные |
150 | 2 |
-
Напишите программу, которая в последовательности целых чисел определяет количество положительных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести количество положительных чисел.
Пример работы программы:
Входные данные | Выходные данные |
−20 | 3 |