Меню
Разработки
Разработки  /  Информатика  /  Уроки  /  10 класс  /  Конспект урока по информатике "Составление программ на операторы ввода и вывода данных, оператора присваивания в среде программирования Турбо Паскаль"

Конспект урока по информатике "Составление программ на операторы ввода и вывода данных, оператора присваивания в среде программирования Турбо Паскаль"

Урок позволит отработать навыки составления программ на Паскале.
26.10.2015

Описание разработки

Цели:

Отработать навыки составление программ на операторы ввода и вывода данных, оператора присваивания в среде программирования Турбо Паскаль

Научить программировать одну и ту же задачу с использованием разных операторов цикла.

Развить навыки программирования в среде Турбо Паскаль.

Развить алгоритмическое мышление учащихся.

Воспитывать культуру работы в парах и группах.

Задачи:

Образовательные – дать определение понятию переменная, рассказать о типах переменных, значениях переменных и взаимосвязи между ними.

Развивающие – развитие внимательности, памяти, алгоритмического мышления школьников.

Воспитательные – развитие познавательного интереса, логического мышления.

План урока:

1. Организационный момент

2. Актуализация знаний

3. Ознакомление с новым материалом

4. Физкультминутка

5. Работа на ПК (составление программы)

6. Домашнее задание.

7. Итоги урока.

Ход урока.

1. Организационный момент. Приветствие учителя учащихся.

Введение. Приветствие.

На протяжении прошлого месяца мы изучали разделы «Основы алгоритмизации и программирования» и раздел «Программирование на Турбо Паскаль». С какими понятиями вы познакомились на прошлых уроках (алгоритм, программа, структура программы в паскаль, переменными)

2. Актуализация (устно). Учитель задает вопросы, дети отвечают.

Что входит в алфавит языка Паскаль?

Какова структура программы в Паскаль?

Что означает. ; =:= ?

Чем отличается = от:= ?

Как запустить программу?

Конспект урока по информатике Составление программ на операторы ввода и вывода данных, оператора присваивания в среде программирования Турбо Паскаль

3. Ознакомление с новым материалом. Учитель сообщает тему урока.

Дети самостоятельно работают с ЭОР.

(http://www.pascal.helpov.net/index/pascal_assignment-operator)

(http://mif.vspu.ru/books/pascal/writeln.html)

Отвечают на вопросы и создают конспект.

Вопросы конспекта:

Для ввода исходных данных чаще всего используется процедура …

Для вывода результатов работы программы на экран используются процедуры: …

Чтение исходных данных логического типа в языке Паскаль допустимо?

Как записывается оператор присваивания?

4. Физкульминутка.

5. Работа на ПК (составление программы).

Дети составляют программу на операторы  ввода и вывода,  оператор присваивания

Пример программы:

Условия: составить программу нахождения y=(3+x+1(1+x2)) sinx, переменная х вводится с клавиатуры.

Решение:

Program Primer1(input,output);

Uses crt;

Var x,y: real;

Begin

Writeln(‘введите число’);

Read(x);

y:=(3+x+1(1+sqr(x))*sin(x);

write(‘y=’, y:5:2);

Весь материал - в документе.

Содержимое разработки

Тема: Составление программ на операторы ввода и вывода данных, оператора присваивания в среде программирования Турбо Паскаль

Цели:

• Отработать навыки составление программ на операторы ввода и вывода данных, оператора присваивания в среде программирования Турбо Паскаль

• Научить программировать одну и ту же задачу с использованием разных операторов цикла.

• Развить навыки программирования в среде Турбо Паскаль

• Развить алгоритмическое мышление учащихся

• Воспитывать культуру работы в парах и группах.

Задачи:

Образовательные – дать определение понятию переменная, рассказать о типах переменных, значениях переменных и взаимосвязи между ними.


Развивающие –  развитие внимательности, памяти, алгоритмического мышления школьников.


Воспитательные – развитие познавательного интереса, логического мышления.


Тип урока: формирования новых знаний.

Форма урока: мультимедиа – урок, практикум, лекция.


Оборудование урока: мультимедийный проектор, экран, раздаточный материал


План урока:

  1. Организационный момент

  2. Актуализация знаний

  3. Ознакомление с новым материалом

  4. физкультминутка

  5. Работа на ПК (составление программы)

  6. Домашнее задание

  7. Итоги урока





Ход урока.

1. Организационный момент. Приветствие учителя учащихся.

2.Введение. Приветствие.

На протяжении прошлого месяца мы изучали разделы «Основы алгоритмизации и программирования» и раздел «Программирование на Турбо Паскаль». С какими понятиями вы познакомились на прошлых уроках (алгоритм, программа, структура программы в паскаль, переменными)

2. Актуализация (устно). Учитель задает вопросы, дети отвечают.

• Что входит в алфавит языка Паскаль?

• Какова структура программы в Паскаль?

• Что означает . ; = := ?

• Чем отличается = от := ?

• Как запустить программу?

3.Ознакомление с новым материалом. Учитель сообщает тему урока.

Дети самостоятельно работают с ЭОР.

(http://www.pascal.helpov.net/index/pascal_assignment-operator)

(http://mif.vspu.ru/books/pascal/writeln.html)

Отвечают на вопросы и создают конспект.

Вопросы конспекта:

  1. Для ввода исходных данных чаще всего используется процедура …

  2. Для вывода результатов работы программы на экран используются процедуры: …

  3. Чтение исходных данных логического типа в языке Паскаль допустимо?

  4. Как записывается оператор присваивания?


4.Физкульминутка.



5. Работа на ПК (составление программы).

Дети составляют программу на операторы ввода и вывода, оператор присваивания

Пример программы:

Условия: составить программу нахождения y=(3+x+1\(1+x2)) sinx, переменная х вводится с клавиатуры.

Решение:

Program Primer1(input,output);

Uses crt;

Var x,y: real;

Begin

Writeln(‘введите число’);

Read(x);

y:=(3+x+1\(1+sqr(x))*sin(x);

write(‘y=’, y:5:2);

Read key

end.

6.Домашнее задание:

А)Выучить оператор ввода, вывода, присваивания.

Б)В решении задачи (Условие: составить программу нахождения s=x2+tgx, переменная х вводится с клавиатуры) найти ошибки:

Program Primer1(input,output);

Uses crt;

Var x,s: real;

Begin

Writeln(‘введите число’);

Read(x);

y:=sqr(x)+sin(x)*cos(x);

write(‘s=’,s);

Read key;

end.



7. Итоги урока.

• Какими видами деятельности вы занимались сегодня?

• Что нового для вас было сегодня на уроке?

• На этом уроке мы научились:

составлять программы для оператора ввода, вывода, присваивания





-80%
Курсы повышения квалификации

Современный урок информатики в условиях реализации ФГОС

Продолжительность 108 часов
Документ: Удостоверение о повышении квалификации
5900 руб.
1180 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Конспект урока по информатике "Составление программ на операторы ввода и вывода данных, оператора присваивания в среде программирования Турбо Паскаль" (20.81 КB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт