Меню
Разработки
Разработки  /  Информатика  /  Уроки  /  8 класс  /  Урок информатики «Решение квадратного уравнения в Паскале»

Урок информатики «Решение квадратного уравнения в Паскале»

Цель урока: повторение решения квадратных уравнений в математике, закрепление знаний умений и навыков в практическом применении условного оператора в Паскале.
05.02.2014

Описание разработки

Цель урока:

 Повторение решения квадратных уравнений в математике.

Закрепление знаний умений и навыков в практическом применении условного оператора в Паскале.

Задачи:

Образовательные: систематизировать знания по применению формул корней квадратных уравнений при решении квадратных уравнений вида ax2+bx+c=0 ;

Обобщить и закрепить знания в использовании условного оператора if… then… else… при решении математических задач.

Развивающие:

развитие логического мышления при решении уравнений методом программирования;

закрепление навыков работы на ПК;

развивать навыки решения квадратных уравнений, умение работать самостоятельно.

познавательного интереса;

формирование информационной культуры, потребности в приобретении и применении знаний на практике;

Воспитательные

воспитание познавательного интереса к предметам (математики и информатики); трудолюбие; навыков самоконтроля.

воспитание стремления к глубокому усвоению данной темы;

Межпредметные связи: применение информационных технологии в решении конкретных задач математики.

Тип урока: интегрированный, урок применения полученных знаний и умений.

Мотивация:

Учитель математики: Есть великое высказывание «Математика – ум в порядок приводит» из этого сразу отпадает вопрос нужно ли изучать математики и информатику. знание, наука. Именно поэтому, если человек умен в математике, то это всегда означало высшую ступень учености. Целью сегодняшнего урока является формирование навыков решения квадратных уравнений с помощью языка программирования Pascal, познакомить вас еще с одним способом решения квадратных уравнений – программированием задач.

Учитель информатики: Современные условия жизни диктуют необходимость изучения информатики. Не одна отрасль науки, производства, культуры, да и быт человека уже невозможен без информационных технологий. Сегодня мы с вами еще раз покажем, как тесно связаны математика и информатика. Пополним свои знания по информатике и математике, решая конкретную задачу.

Оборудование: компьютерный класс, проектор, лицензионное программное обеспечение.

Форма проведения урока: практическая работа, с элементами вовлеченного обучения, самоконтроль, беседа.

Программная поддержка: язык программирования Паскаль, Microsoft PowerPoint

Учебные места: кабинет информатики

Учитель математики:

Давайте вспомним, что понимают под квадратным уравнением и как решается квадратное уравнение? (уравнение вида ах2+bх+с=0)

Вопросы:

Назовите формулу дискриминанта. (D=b2 - 4ac)

В каком случае квадратное уравнение имеет два корня, один корень не имеет корней, имеет вид линейного уравнения?

  (если D>0, то два корня, если D=0, то один корень, если D <0, то нет корней, если а=0 имеет вид линейного уравнения)

Запишите формулу корней Х1 =  , Х2=

Пример:

2 - 5х+2=0

D=b2 - 4ac=52 - 4*2*2=25 - 16 =9

D>0, два корня

Х1= ( - b+√d)/2*a (x1= - 0, 5)  

X2 =( - b - √d)/2*a (x2= - 2)

Учитель информатики:

Для решения поставленной задачи вспомним основы Паскаля (приложение презентация – тест)

презентация Тест по Паскалю

На прошлом занятии мы составили блок схему алгоритма решения квадратного уравнения

Давайте вспомним, как по заданному решению составить блок - схему алгоритма в тетради.

Приложение 2 блок схема

 Подпишем основные элементы блок - схемы применительно к языку программирования.

Используя запись и блок - схему квадратного уравнения, необходимо составить программу на языке Pascal для проверки математического решения.

Program kvur;

Uses CRT;

Var a, b, c, d, x1, x2: real;

Begin

Clrscr;

Write('введите коэффициенты уравнения, a, b, c'); readln(a, b, c);

D:=b*b - 4*a*c;

Write('корни уравнения', ' ');

X1:=( - b+sqrt(d))/(2*a); x2:=( - b - sqrt(d))/(2*a);

Writeln('x1=', x1, ' ', 'x2=', x2);

 End.

Работа по группам

Весь материал - смотрите архив.

-75%
Курсы повышения квалификации

Внедрение современных педагогических технологий в условиях реализации ФГОС (в предметной области «Информатика»)

Продолжительность 72 часа
Документ: Удостоверение о повышении квалификации
4000 руб.
1000 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Урок информатики «Решение квадратного уравнения в Паскале» (0.16 MB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт