Запись алгоритмов на языке программирования Pascal
Список вопросов теста
Вопрос 1
Определите значение целочисленных переменных a и b после выполнения фрагмента программы:
a := 2468;
b := (a mod 1000)*10;
a := a div 1000 + b;
Варианты ответов
- a=22, b=20
- a=4682, b=4680
- a=8246, b=246
- a=470, b=468
Вопрос 2
Определите значение переменной c после выполнения следующего фрагмента программы, в котором a, b и с – переменные вещественного (действительного) типа:
a := 120;
b := 100;
a := a + b / 2;
if b < a / 2
then c := b + a
else c := b + a / 2
Варианты ответов
- с = 155
- с = 160
- с = 185
- с = 270
Вопрос 3
Определите значение переменной P после выполнения следующего фрагмента программы:
P:=1; i:=3;
while i <= 9 do
begin
P := P * (i div 3);
i := i + 1;
end
Варианты ответов
- 1
- 3
- 9
- 24
Вопрос 4
Определите значение переменной y, которое будет получено в результате выполнения следующей программы:
var n, y: integer;
begin
y := 0;
for n := 6 downto 3 do
begin
y := y + 1;
y :=y * 2;
end
end.
Вопрос 5
Определите, что будет напечатано в результате работы следующего фрагмента программы:
var k, s: integer;
begin
s:=0;
k:=1;
while s < 66 do
begin
k:=k+3;
s:=s+k;
end;
write(s);
end.