Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Входная контрольная работа Информатика 9 класс (доп. задания Python)

Входная контрольная работа Информатика 9 класс (доп. задания Python)

Avatar
11.09.2023. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Входная контрольная работа Информатика 9 класс (доп. задания Python)

Список вопросов теста

Вопрос 1

В программе «=» обозначает оператор присваивания; знаки «+», «−», «*» и «/» − соответственно операции сложения, вычитания, умножения и деления. Правила выполнения операций и порядок действий соответствует правилам арифметики.

Определите значение переменной а после выполнения алгоритма:

 

a = −12

b = 14 − a / 2

b = (b − a) / 8

a = b * 2 + 6

 

В ответе укажите одно целое число − значение переменной а.

Вопрос 2

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.

s = 100
for k in range(11): 
    s = s − 5
print (s)
Вопрос 3
Определите значение переменной с после выполнения следующего фрагмента программы. Ответ запишите в виде целого числа.
 
a = 30
b = 18
a = 3 * b - a
if a > b:
    с = 2 * a - b
else:
    c = 2 * a + b
Вопрос 4

В алгоритме используются целочисленные переменные a и b.

Определите значение переменной a после исполнения алгоритма:

a = 6
b = 2
b = a // 2 // b
a = 2 ** a + 3 ** b

Вопрос 5

В какой строке правильно записан вывод значения переменной на экран?

1. a = int(input))

2. b=input(int())

3. c=int(input())

4. s=a+b+c

5. print(s)

Вопрос 6

Ниже приведена программа

s = int(input())
t = int(input())
if s > 12 or t > 12:
    print("YES")
else:
    print("NO")

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

 

(1, 13); (14, 2); (1, 12); (11, 12); (–14, –14); (–11, 13); (–4, 11); (2, 9); (8, 6).

 

Сколько было запусков, при которых программа напечатала «YES»?

 

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт