Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Ветвление в Pascal. Параграф 3.4

Ветвление в Pascal. Параграф 3.4

Avatar
10.05.2022. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тест рассчитан на учеников 8 класса. УМК: Босова. по теме Ветвление в Pascal. Время на выполнение теста ограничено. Порядок заданий случайный.

Список вопросов теста

Вопрос 1

Какое условие записано верно для определения четности переменной  а

 

Варианты ответов
  • a mod 2 = 0
  • a mod 2 = 1
  • a div 2 = 0
  • a div 2 = 1
Вопрос 2

Выберите правильно записанные условия на языке Pascal 

 

Варианты ответов
  • x >< 1
  • x <= 2
  • (x >3) or (y=5)
  • x + 2 > 0
  • x div 3 = 1
  • 0 < x < 7
  • y > x + 4
  • x, y > 5
  • y mod 2 = 0
Вопрос 3

Какая логическая операция называется логическим умножением

 

Варианты ответов
  • or
  • and
  • not
  • end
  • do
Вопрос 4

Значение переменной z после выполнения программы:

x:=6; y:=4;z:=0;

if      x mod y = 1       then  z:=x-y   else    z:=x+y;

write (z);

Вопрос 5

Что произойдет в результате выполнения программы, представленной ниже:
program pr;

 var а, b, с: integer;

begin write (‘Введите первое целое число’);

readln (а); write (‘Введите второе целое число’);

readln (b);

if а>b then с:=2*а else с:=2*b;

writeln (с);

 end.
 

Варианты ответов
  • уменьшение большего из двух чисел вдвое
  • увеличение меньшего из двух чисел вдвое
  • увеличение большего из двух чисел вдвое
  • уменьшение меньшего из двух чисел вдвое
Вопрос 6

Укажите верную запись условного оператора

 

Варианты ответов
  • if х<у then х:=0 else read (у);
  • if х>=у then х:=0; у:=0 else write (z);
  • if x
  • if х<у then х:=0 else write (z) ;
Вопрос 7

Определите значение переменной с после выполнения следующего фрагмента программы.

а:=100;
b:=30;
а:=а-b*3;
if a>b then c:=a-b else c:=b-a;

Вопрос 8

Условный оператор

if a mod 2=0 then write ('Да') else write ('Нет') позволяет определить, является ли число а:

 

Варианты ответов
  • целым
  • двузначным
  • чётным
  • нечётным
  • простым
Вопрос 9

Результатом выполнения фрагмента алгоритма

a:=7;

b:=8;

k:=5+a;

if a>b then k:=k*3

else k:=k-3;

writeln (k);

 

Вопрос 10

Результатом выполнения фрагмента алгоритма  при х= - 22

WRITE (‘Введите число’);

READ ( X);

IF X<=10 THEN Y:=х*10 ELSE Y:=X*X*X ;

WRITE (Y);

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт