Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  Тест Python

Тест Python

Avatar
12.05.2024. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тест на повторение знаний по пройденному материалу

Список вопросов теста

Вопрос 1

Какие существуют типы переменных (выбрать несколько выриантов):

Варианты ответов
  • int
  • float
  • num
  • list
  • integer
Вопрос 2

Переменная int:

Варианты ответов
  • вещественная переменная
  • символьная строк
  • логическая переменная
  • целая переменная
Вопрос 3

Переменная str:

Варианты ответов
  • символьная строка
  • логическая переменная
  • целая переменная
Вопрос 4

Переменная float:

Варианты ответов
  • целая переменная
  • вещественная переменная
  • логическая переменная
Вопрос 5

Имена переменных не могут включать:

Варианты ответов
  • Русские буквы
  • Латинские буквы
  • Пробелы
  • Скобки, знаки + = ! ? b др.
Вопрос 6

Какие имена являются правильными в PYTHON (выбрать несколько):

Варианты ответов
  • N
  • ABC
  • sum
  • 41And
  • A+B
  • _mam
Вопрос 7

Что будет в результате выполнения комманды:

a = 20

b = a + 5

a = b * 100

print(a)

Вопрос 8

Что будет в результате следующего действия print(2**20)?

Варианты ответов
  • 1048576
  • 2
  • 220
  • 0
Вопрос 9

Что будет в результате выполнения следующего действия print(23 % 2)?

Варианты ответов
  • 11
  • 1
  • 0
Вопрос 10

Результатом вычисления print(24 // 3) будет число:

Варианты ответов
  • 4
  • 8
  • 12
Вопрос 11

Что будет результатом выполнения алгоритма при а = 5, b = 7:

a = int(input())

b = int(input())

s = a + b

print(s)

Вопрос 12

Что будет в результате выполнения следующего алгоритма (Входные данные: -57):

x = int(input())
if x > 0:
    print(x)
else:
    print(-x)

Вопрос 13

Какой ряд чисел образуется после выполнения следующего алгоритма: 


for i in range(1,10):
        print(i)

Варианты ответов
  • 1 2 3 4 5 6 7 8 9
  • 0 1 2 3 4 5 6 7 8 9 10
  • 0
  • 1 2 3 4 5 6 7 8 9 10
Вопрос 14

Какой ряд чисел образуется после выполнения алгоритма:

 
for i in range(1,10+1):
        print(i)

Варианты ответов
  • 1 2 3 4 5 6 7 8 9 10
  • 1 2 3 4 5 6 7 8 9 10 11
  • 0 1 2 3 4 5 6 7 8 9 10
Вопрос 15

Что выведет программа после выполнения данного алгоритма: 

Входные данные: Иванов

print('Как Ваша фамилия?')

name = input()

print('Здравствуйте, '+ name + '!')

Варианты ответов
  • Как Ваша фамилия? Здравствуйте, Иванов!
  • Как Ваша фамилия? Здравствуйте, Иванов
  • Как Ваша фамилия? Здравствуйте,Иванов !
Вопрос 16

Как обозначается логический оператор И, ИЛИ, НЕ в питоне:

Варианты ответов
  • OR, NOT, IF
  • AND, OR, NOT
  • AND, OR, IF
  • AND, ELSE, NOT
Вопрос 17

Что будет в результате выполнения следующего алгоритма программы: 

Входные данные: 15, 45

a = int(input())
b = int(input())
if a % 10 == 0 or b % 10 == 0:
    print('YES')
else:
    print('NO')

Варианты ответов
  • YES
  • NO
Вопрос 18

Как будет записано число 18 после выполнения следующего алгоритма: 

x = float(input())
print(x)

Варианты ответов
  • 18
  • 18.0
  • 18.00
Вопрос 19

Что будет после выполнения следующего листинга программы:

for i in range(4)
    print(i)
    print(i ** 2)

Варианты ответов
  • 0123
  • 00112439
  • 00112439416
Вопрос 20

Результатом выполнения алгоритма цикла while будет:

i = 1
while i <= 10:
    print(i ** 2)
    i = i + 1

Варианты ответов
  • 1 4 9 16 25 36 49 64 81 100
  • 1 2 3 4 5 6 7 8 9 10
  • 1 2 4 16 25 36 49 64 81
Вопрос 21

Как получить данные от пользователя?

Варианты ответов
  • Использовать метод read()
  • Использовать метод input()
  • Использовать метод get()
Вопрос 22

Какая функция выводит что-либо в консоль (на экран монитора)?

Варианты ответов
  • out();
  • log();
  • print();
  • write();
Вопрос 23

Тело цикла - это...

Варианты ответов
  • группа команд, не входящих в циклическую структуру
  • произвольный текст
  • произвольная группа команд
  • группа команд, повторяющихся некоторое число раз
Вопрос 24

Если говорят, что программа "зациклилась", то это значит...

Варианты ответов
  • тело цикла не выполняется
  • тело цикла выполняется бесконечно долго
  • тело цикла выполняется только один раз
Вопрос 25

Укажите, сколько раз выполнится тело цикла с данным заголовком: 

Варианты ответов
  • 10
  • 2
  • 12
  • 9
Вопрос 26

Запись
if  <условие>:
    оператор
называется 

Варианты ответов
  • полной формой условного оператора
  • неполной формой условного оператора
  • составным условием
  • простым условием
Вопрос 27

Запись
if  <условие>:
    <оператор1>
else:
    <оператор2>
называется  

Варианты ответов
  • полной формой условного оператора
  • неполной формой условного оператора
  • составным условием
  • простым условием
Вопрос 28

if  <условие>:
    <оператор1>
else:
    <оператор2>
Если условие ложно, то:

Варианты ответов
  • выполняется оператор 1
  • выполняется оператор 2
  • операторы не выполняются
  • выполняются оба оператора
Вопрос 29

if  <условие>:
    <оператор1>
else:
    <оператор2>
Если условие истино, то:

Варианты ответов
  • выполняется оператор 1
  • выполняется оператор 2
  • операторы не выполняются
  • выполняются оба оператора
Вопрос 30

Что будет выведено на экран после выполнения фрагмента программы:
x=6
y=x+2
if y>=x :
   print(y+x)
else:
    print(y-x)

Вопрос 31

Что будет выведено на экран после следующего фрагмента программы:
r=8
s=r-2
if s>r or r%2==0:
    print(r+2*s)
else:
    print(s+r*2)

Вопрос 32

Что выведет данный код?

if 1:

    print(0)

 

 

Варианты ответов
  • 1
  • 0
  • ошибку
  • 0
Вопрос 33

Что выведет данный код?

x='one' if x==1 else 'other'

print (x)

Варианты ответов
  • one
  • other
  • 1
  • ошибку
Вопрос 34

 

Установите порядок в котором используются операторы в программе:

Варианты ответов
  • if
  • elif
  • else
Вопрос 35

В какой строке допущена ошибка?

1.a = int(input())
2.if a>0:
3.    print(a):
4.else:
5.    print('hello')

Варианты ответов
  • 1
  • 2
  • 3
  • 4
  • 5
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт