Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Тест. PYTHON. Тест за 3 четверть

Тест. PYTHON. Тест за 3 четверть

Avatar
18.03.2021. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Итоговая работа за 3 четверть. Программирование. PYTHON

Список вопросов теста

Вопрос 1

Оператор вывода в языке Phyton3:

Варианты ответов
  • float ()
  • print ()
  • int ()
  • input ()
Вопрос 2

s = float (input ())

Варианты ответов
  • значение переменной s сравнивается со значением, введенным с клавиатуры
  • переменной s присваивается целочисленное значение, введённое с клавиатуры
  • переменной s присваивается дробное значение, введённое с клавиатуры
  • значение переменной s выводится на экран
Вопрос 3

t==0

Варианты ответов
  • переменной t присваивается значение, введённое с клавиатуры
  • переменной t присваивается значение 0
  • на экран выводится значение 0
  • значение переменной t сравнивается с 0
Вопрос 4

Фрагмент программы

if t > s:
     print (s)
else:
     print (t)

Варианты ответов
  • находит наибольшее из двух чисел
  • находит наименьшее из двух чисел
  • находит чётное число
  • находит положительное число
Вопрос 5

Фрагмент программы

if t % 2 == 0:
     print (‘yes’)
else:
     print (‘no’)

Варианты ответов
  • находит чётное ли число
  • находит наименьшее из двух чисел
  • находит наибольшее из двух чисел
  • находит положительное число
Вопрос 6

Чтобы ввести с клавиатуры дробное число,
используется конструкция

Варианты ответов
  • n = input (‘Введите число ’)
  • print (‘Введите число ’, c)
  • u = int (input (‘Введите число ’))
  • k = float (input (‘Введите число ’))
Вопрос 7

Требуется написать программу нахождения суммы цифр двухзначного числа.
Какая из строк выполнит эту задачу?

Варианты ответов
  • b = a // 10 + a % 10
  • s = x * 10 + x / 10
  • if a + b > 0:
  • print (x + y)
Вопрос 8

Конструкция d != 2 означает

Варианты ответов
  • переменной d присваивается значение 2
  • четная величина
  • значение переменной d не равно 2
  • значение переменной d равно 2
Вопрос 9

Значение переменной p в выражении
p = 10 – 12 / w * 2+ 4

при w=3

Варианты ответов
  • 10
  • 11
  • 9
  • 6
Вопрос 10

Как называется число, которое указывает на конкретный элемент массива и записывается в квадратных скобках?

Варианты ответов
  • индекс элемента массива
  • значение элемента массива
  • имя массива
Вопрос 11

Какой индекс имеет последний элемент массива A?
A = [8]*6

Варианты ответов
  • 4
  • 3
  • 5
  • 6
Вопрос 12

Требуется заполнить массив именно так:

  X = [1 3 5 7 9 11]

Какой оператор надо поместить в тело цикла вместо многоточия?

  X = [0]*6
  for k in range(6):
     ...
Варианты ответов
  • X[k] = k
  • X[k] = 2*k
  • X[k] = 2*k - 1
  • X[k] = 2*k + 1
Вопрос 13

Обращение к элементу массива осуществляется по его:

Варианты ответов
  • индексу
  • имени и индексу
  • имени
Вопрос 14

Описание массива производится для того, чтобы:

Варианты ответов
  • человек помнил количество ячеек в массиве
  • компьютер запомнил имя массива
  • компьютер зарезервировал память для хранения элементов массива
  • компьютер составил алгоритм для обработки массива
Вопрос 15

Числовой массив А заполнен последовательно числами: 2, 5, 7, 34. Укажите значение элемента А[3].

Варианты ответов
  • 2
  • 5
  • 7
  • 34
Вопрос 16

Что такое массив?

Варианты ответов
  • это простой тип данных, состоящий из одного элемента
  • это структурированный тип данных, состоящий из элементов разных типов
  • это структурированный тип данных, состоящий из элементов одного типа, упорядоченных по номеру и объединенных под одним именем
Вопрос 17

Числовой массив А заполнен последовательно числами: 7, 15, 87, 34.
Укажите значение элемента А[2].

Варианты ответов
  • 7
  • 15
  • 87
  • 34
Вопрос 18

Что называют индексом массива? 

Варианты ответов
  • Объем массива
  • Размерность массива
  • Номер элемента
  • Ширина массива
Вопрос 19

Что производит следующий фрагмент программы?

from random import randint
n=int(input('введите число '))
a = [0]*n
for i in range(n):
       a[i]=randint(-10,10)
print(a)

Варианты ответов
  • Заполняет массив случайными числами и не выводит их на экран.
  • Заполняет массив случайными числами и выводит их на экран.
  • Заполняет массив одинаковыми числами и выводит их на экран.
Вопрос 20

Укажите, какой из вариантов является правильным для обращения к первому элементу массива 

Варианты ответов
  • a[0]
  • a(0)
  • a[1]
  • a(1)
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт