Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Тест ПИТОН

Тест ПИТОН

Avatar
08.04.2020. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тест Язык программирования ПИТОН

Список вопросов теста

Вопрос 1

Определите значение переменной A после выполнения фрагмента программы:

  a = 15

  if a < 5:

    a = 5

Варианты ответов
  • 5
  • 15
  • 0
Вопрос 2

Определите значение переменной A после выполнения фрагмента программы:

  a = 15

  if a > 5: 

    a = 10

Варианты ответов
  • 10
  • 15
  • 0
Вопрос 3

Определите значение переменной A после выполнения фрагмента программы:

  a = 11

  if a < 6:

    a += 13

  else:

    a -= 8

Варианты ответов
  • 3
  • 24
  • 11
Вопрос 4

Определите значение переменной A после выполнения фрагмента программы:

  a = 11

  if a < 16:

    a += 13

  else:

    a -= 8

Варианты ответов
  • 24
  • 3
  • 11
Вопрос 5

Определите значение переменной A после выполнения фрагмента программы:

  a = 10

  if a < 5: a += 12

  else:     a -= 7

  if a < 5: a += 12

  else:     a -= 7

Варианты ответов
  • 15
  • 10
  • 22
Вопрос 6

Определите значение переменной A после выполнения фрагмента программы:

  a = 11;

  if a > 5: a += 13

  else:     a -= 9

  if a > 5: a += 13

  else:     a -= 9

Варианты ответов
  • 24
  • 37
  • 15
Вопрос 7

Определите значение переменной A после выполнения фрагмента программы:

  a = 11

  b = 4

  if a > b: b += 13

  else:     a -= 8

  if a > b: a += 13

  else:     a -= 8

Варианты ответов
  • 3
  • 24
  • 16
Вопрос 8

Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 4 раза?

  i = 2

  while i <= ...:   

    print ( "Hello!" )

    i += 1

Варианты ответов
  • 5
  • 7
  • 4
Вопрос 9

Сколько раз будет выполнен этот цикл?

  i = 2

  while i < 8:

    print ( " Hello!" )

    i += 1

Варианты ответов
  • 7
  • 8
  • 9
Вопрос 10

Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?

  i = ...

  while i <= 4:

    print ( " Hello!" )

    i += 1

Варианты ответов
  • 3
  • 4
  • 2
Вопрос 11

Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?

  i = ...

  while i >= 4:

    print ( " Hello !" )

    i -= 1

Варианты ответов
  • 5
  • 4
  • 6
Вопрос 12

Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?

  i = 3

  while i >= ...:

    print ( " Hello!" )

    i -= 1

Варианты ответов
  • 2
  • 4
  • 3
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт