Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Тест «Начальные сведения языка Python»

Тест «Начальные сведения языка Python»

Avatar
19.05.2025. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тест «Начальные сведения языка Python» для учеников 8 класса, время выполнения теста 35 минут.

Список вопросов теста

Вопрос 1

Что хранит в себе переменная?

Варианты ответов
  • Имя
  • Значение
  • Тип
  • Длину своего значения
Вопрос 2

Что обозначает тип данных int?

Варианты ответов
  • Целочисленное
  • Вещественное
  • Строковое
  • Булевое
Вопрос 3

Выберите правильную запись оператора присваивания:

Варианты ответов
  • 10 = х
  • у = 7,8
  • а = 5
  • а == b + x
Вопрос 4

Укажите оператор ввода

Варианты ответов
  • input()
  • print()
  • int()
  • random()
Вопрос 5

Какие операторы  используется в следующей  записи?

 if  n < 100:

     b = n + a

 

Варианты ответов
  • Условный оператор
  • Оператор присваивания
  • Оператор сложения
  • Оператор умножения
Вопрос 6

Укажите цикла в языке Python

Варианты ответов
  • while
  • for
  • if
  • print
Вопрос 7

Сколько раз выполнится цикл?

total = 100

i = 0

while i < 5:

    n = int(input())

    total = total - n

    i = i + 1

print ("Осталось", total)

Вопрос 8

Что делает функция len()?

Варианты ответов
  • Возвращает длину строки
  • Возвращает случайное число
  • Возвращает номер символа
  • Возвращает модуль числа
Вопрос 9

Выберите циклический алгоритм

1.

k = 0

while k < 10:

     print(“Привет”)

     k = k +1

 

2.

a = int(input())

b = int(input())

c = int(input())

s = a+b+c

print(c)

3.

a = int(input())

if a > 0:

   print(a)

else:

    print(a)

Вопрос 10

В какой строке правильно записан ввод числа с клавиатуры?

Варианты ответов
  • a = int(input))
  • b=input(int())
  • c=int(input())
  • s=a+b+c
  • print(s)
Вопрос 11

Запишите номера строк, в которых  допущена ошибка через запятую

  1. a = int(input())
  2. if a>0:
  3.     print(a):
  4. else
  5.     print(A)

 

Вопрос 12

Сколько раз программа напишет слово «Пока»?

k=0

while k<10:

    print(«Привет»)

    k = k+1

Варианты ответов
  • 9
  • 0
  • 10
Вопрос 13

Какие величины могут изменять свое значение при выполнении программы?

 

Варианты ответов
  • константы
  • переменные
  • служебные слова
Вопрос 14

Выберите правильные имена переменных

Варианты ответов
  • D
  • D1
  • Dlina
  • Длина
Вопрос 15

Как в языке Python обозначается целочисленный тип данных?

Варианты ответов
  • float
  • int
  • str
  • bool
Вопрос 16

Как в языке Python обозначается любые числа с дробной частью

Варианты ответов
  • float
  • int
  • str
  • bool
Вопрос 17

Какая арифметическая операция выполняется в выражении: 9 // 2

Варианты ответов
  • целочисленное деление
  • нахождение остатка от деления
  • возведение в степень
  • деление
Вопрос 18

Определите, что будет результатом выполнения арифметического выражения: 9%2

Вопрос 19

Что будет в результате выполнения следующего действия

print((14%3)*2)

Вопрос 20

Что будет в результате выполнения следующего действия

print((29//3)/3)

Вопрос 21

Что будет выведено на экран монитора в результате программы:

y = 5
x=3
z = x**3+9*y
print(z)

Вопрос 22

Какое значение будет выведено на экран дисплея, если x = 6

y = x + 2
if y >= x:
    print (x + y)
else:
    print (y - x)

Вопрос 23

Что будет выведено на экран?

f = 9
h = f - 6
if f <= h:
     print (h + f * 2)
else:
    print (f - h * 2)

Вопрос 24

Что будет выведено на экран?

r = 8
s = r - 2
if s > r or r %2 = = 0:
     print(r + 2 * s)
else:
      print(s + r * 2)

Вопрос 25

Что будет выведено на экран?

a = 10
b = 1
while (a>4):
   a = a - 1
   b = b + 5
print(b)

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт