Тест. Язык программирования Pascal. Операторы присваивания, ввода и вывода.
Список вопросов теста
Вопрос 1
Чему равно значение переменной а после выполнения программы:
program qq;
var a, b: integer;
begin
a := 5;
b := a + 2;
a := (a + 2)*(b - 3);
end.
Вопрос 2
Что будет выведено на экран в результате выполнения фрагмента алгоритма:
X1:=7;
X2:=8;
writeln(X1);
Варианты ответов
- 7
- 8
- Х1
- Х1=7
Вопрос 3
Что будет выведено на экран в результате выполнения фрагмента алгоритма:
X1:=13;
X2:=15;
writeln('X2=');
Варианты ответов
- Х2=
- 13
- 15
- Х2=15
Вопрос 4
Что будет выведено на экран в результате выполнения фрагмента алгоритма:
X1:=3;
X2:=5;
writeln(X1,X2);
Варианты ответов
- Х1,Х2
- 5
- 35
- 3
Вопрос 5
С помощью какой команды мы можем ввести значение переменной A клавиатуры?
Варианты ответов
- read(A)
- write(A)
Вопрос 6
Что будет выведено на экран в результате выполнения фрагмента алгоритма:
X2:=5;
readln(X1);
writeln(X1+X2);
Если при работе фрагмента с клавиатуры было введено число 10?
Вопрос 7
Что будет выведено на экран в результате выполнения фрагмента алгоритма:
readln(В,А);
С:=2*А+В
writeln(С);
Если при работе фрагмента с клавиатуры были введены числа 10 и 15 ?
Вопрос 8
После выполнения программы, записанной на языке Паскаль
program prim;
var s: integer;
begin s:=15;
write (‘s=’, s)
end.
на экран будет выведено
Варианты ответов
- 's='15
- s:=15
- s=15


