Меню
Тесты
Тесты  /  Информатика  /  Прочее  /  Python. Циклы с параметром. Вариант 1

Python. Циклы с параметром. Вариант 1

Avatar
27.04.2020. Тест. Информатика, Прочее
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Вам предлагается ответить на несколько вопросов по теме "циклы с параметром"

Список вопросов теста

Вопрос 1

При помощи какого из блоков в блок-схеме изображается цикл с параметром?

Вопрос 2

Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?

a = 10;
for i in range(2):
    a -= 1
Вопрос 3

Какое будет максимальное значение i при исполнении цикла?

for i in range (1, 4):

<тело цикла>

Вопрос 4

Установите соответствие между циклами на языке Python и их типами

1.

Цикл с постусловием

2.

Цикл с параметром

3.

Цикл с предусловием

Варианты ответов
Вопрос 5

Что нельзя делать в теле цикла с параметром?

Варианты ответов
  • Обращаться к внешним переменным
  • Использовать строковые переменные
  • Использовать значение параметра
  • Изменять значение параметра
Вопрос 6

Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?

  a = 2
  for i in range(5):
    a += i
Вопрос 7

Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?

  a = 4
  for i in range(4):
    a += a
Вопрос 8

Какое число будет выведено на экран после выполнения этого фрагмента программы?

  for i in range(3,-1,-1):
    print ( i, end="" )
Вопрос 9

Какое число будет выведено на экран после выполнения этого фрагмента программы?

  print ( 4, end="" )
  for i in range(2,1,-1):
    print ( 2*i, end="" )
Вопрос 10

Какое число будет выведено на экран после выполнения этого фрагмента программы?

  print ( 1, end="" )
  for i in range(3,6):
    print ( i, end="" )
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт