Меню
Тесты
Тесты  /  Информатика  /  Прочее  /  Python. Программирование циклических алгоритмов. Вариант 2

Python. Программирование циклических алгоритмов. Вариант 2

Avatar
09.04.2025. Тест. Информатика, Прочее
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
На выполнения теста дается 20 минут. Для получения оценки необходимо ответить на 10 вопросов.

Список вопросов теста

Вопрос 1

Используется оператор for i in range (-5,9):

При первом выполнении тела цикла i = ...

Вопрос 2

Дан текст программы:

s=0
a=int(input())
while a!=0:
  if (a % 6 == 0) and (a % 10 == 4):
    s+=a
  a=int(input())
print(s)

Какое значение будет присвоено переменной s в результате выполнения этой программы при следующем входном потоке данных: 12, 24, 36, 48, 54, 0?

Вопрос 3

Чему равно значение переменной s после выполнения следующего фрагмента программы:
s=0
for i in range (0,5):
    s+=i

Варианты ответов
  • 5
  • 4
  • 0
  • 10
Вопрос 4

Используется оператор

for i in range (-10,10) ...

После завершения выполнении тела цикла i = ..

Вопрос 5

Какое число будет выведено на экран после выполнения этого фрагмента программы?

  for i in range(3,-1,-1):
    print ( i, end="" )
Вопрос 6

Укажите, сколько раз будет выполнен цикл

for i in range (-1, 3):

   b=b+5

Варианты ответов
  • 4
  • 2
  • Бесконечно
  • 1
  • 3
  • 0
Вопрос 7

Чему равно значение переменной s после выполнения следующего фрагмента программы:
s = 0
for i in range (1,5):
    s = s + 1

Варианты ответов
  • 5
  • 16
  • 6
  • 4
Вопрос 8

Какой оператор цикла желательно  использовать, если известно условие выполнения тела цикла?

Варианты ответов
  • while True: <оператор1, …> if <условие>: break
  • for <параметр> in range ( <начальное значение, <конечное значение>): <оператор>
  • while <условие>: <тело цикла>
Вопрос 9

Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?

  a = 4
  for i in range(4):
    a += a
Вопрос 10

Используется оператор

for i in range (21, 31) ...

После завершения выполнении тела цикла i = ...

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт