Меню
Тесты
Тесты  /  Информатика  /  Прочее  /  Python. Программирование циклических алгоритмов. Вариант 1

Python. Программирование циклических алгоритмов. Вариант 1

Avatar
09.04.2025. Тест. Информатика, Прочее
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
На выполнения теста дается 20 минут. Для получения оценки необходимо ответить на 10 вопросов.

Список вопросов теста

Вопрос 1

Цикл в фрагменте программы 

a=1
b=1
while a+b<8:
    a=a+1
    b=b+2

выполнится:

Варианты ответов
  • 3 раза
  • бесконечное число раз
  • 2 раза
  • 1 раз
  • 0 раз
Вопрос 2

Какой оператор цикла желательно использовать, если известно число повторений тела цикла?

Варианты ответов
  • while <условие>: <тело цикла>
  • while True: <оператор1, …> if <условие>: break
  • for <параметр> in range ( <начальное значение, <конечное значение>): <оператор>
Вопрос 3

Какого оператора цикла не существует в языке Python?

Варианты ответов
  • repeat
  • while
  • for
Вопрос 4

Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?

a = 10;
for i in range(2):
    a -= 1

В ответе запишите только число.

Вопрос 5

Какое будет максимальное значение i при исполнении цикла?

for i in range (1, 4):

        <тело цикла>

В ответе укажите только число.

Вопрос 6

Дана программа:

n = int(input())
mx = 0
for i in range (n):
     x = int(input())
if x % 5 == 0 and x > mx:
     mx = x
print(mx)

Какое значение будет присвоено переменной mx  в результате выполнения этой программы при следующем входном потоке данных: 4, 45, 78, 50, 15?

Вопрос 7

Определите, какое значение будет выведено на экран в результате выполнения приведенной ниже последовательности операторов:

a = 1

b = 1
while a < 32:
    a = a*2
    b = b+a
print (b)

Варианты ответов
  • 64
  • 127
  • 128
  • 33
  • 63
Вопрос 8

Что нельзя делать в теле цикла с параметром?

Варианты ответов
  • Обращаться к внешним переменным
  • Использовать строковые переменные
  • Использовать значение параметра
  • Изменять значение параметра
Вопрос 9

Дана программа:

x=10
k=0
for i in range (10,-11,-1):
    k+=i
    x+=1
k/=x
print('{:4.1f}'.format(k))

Цель программы - 

Варианты ответов
  • найти среднеарифметическое всех целых чисел от -10 до 10
  • найти произведение всех целых чисел от 10 до -10
  • найти произведение всех целых чисел от -10 до 11
  • найти сумму всех целых чисел от 10 до -11
  • найти сумму всех целых чисел от -10 до 10
  • найти среднеарифметическое всех целых чисел от -11 до 10
Вопрос 10

Какое число будет выведено на экран после выполнения этого фрагмента программы?

  print ( 1, end="" )
  for i in range(3,6):
      print ( i, end="" )
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт