Меню
Тесты

Python

Avatar
20.03.2023. Тест. Информатика, Прочее
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
проверка теоретических знаний по языку программирования Python

Список вопросов теста

Вопрос 1

Какие значения из указанных могут принимать переменные типа int?

Варианты ответов
  • -10
  • 'a10c'
  • 10
  • 7.8
Вопрос 2

Определите порядок выполнения операций в указанной инструкции?

(запишите цифры подряд без пробела, например: 23145)
 

Вопрос 3

Какое значение будет у переменной val после выполнения инструкции?
val = 3 ** 4 - 2

Вопрос 4

Выберите инструкцию, присваивающую переменной a значение, введённое пользователем с клавиатуры.

Варианты ответов
  • a = print ()
  • print (a)
  • input (a)
  • a = input ()
Вопрос 5

Данные какого типа возвращает функция input ()?

Варианты ответов
  • int
  • float
  • str
  • bool
Вопрос 6

Что будет выведено на экран в результате выполнения инструкции
print (2, 'a', 8)?

Вопрос 7

Что будет выведено на экран в результате выполнения инструкции
print (2, 'a', 8, sep = ', ')?

Вопрос 8

Как называются алгоритмы, в которых команды выполняются последовательно в том порядке, в котором они записаны?

Варианты ответов
  • Разветвляющиеся
  • Линейные
  • Циклические
  • Последовательные
Вопрос 9

Сопоставьте значения данных и их типы.

1.

int

2.

float

Варианты ответов
  • -10
  • 4/2
  • 0.2e+01
  • 3+2
  • 0
  • 2
Вопрос 10

Запишите результат операции -9 // 5.

Вопрос 11

Как называется алгоритмическая конструкция, которая в зависимости от некоторого условия исполняет одну из двух последовательностей действий?

Варианты ответов
  • Следование
  • Ветвление
  • Цикл
  • Рекурсия
Вопрос 12

Какие значения могут принимать переменные логического типа в языке Python?

Варианты ответов
  • True
  • -10
  • 10
  • False
Вопрос 13

Какой из блоков обязательно присутствует в сокращённой форме записи ветвления?

Варианты ответов
  • if
  • else
  • elif
  • print
Вопрос 14

Какое значение, должна иметь переменная s, чтобы в ветвлении с условием s != 0 выполнился блок else?

Вопрос 15

Как называются алгоритмы, содержащие конструкцию повторения?

Варианты ответов
  • Разветвляющиеся
  • Линейные
  • Циклические
  • Последовательные
Вопрос 16

Какое будет значение i после исполнения инструкций?
i = 0
n =625
while n > 0:
    n = n // 5
    i = i +1

Вопрос 17

Сколько раз будет выполнено тело цикла?
for i in range (4):
<тело цикла> 

Вопрос 18

Какое будет максимальное значение i при исполнении цикла?
for i in range (1, 4):
     <тело цикла>

Вопрос 19

Сколько раз будет выполнено тело цикла?
for i in range (2, 8, 2):
    <тело цикла>

Вопрос 20

Чему будет равна переменная «c» после выполнения этой программы:
  a = 20
  b = 3
  b = a % b + 4
  c = a % b + 1

Вопрос 21

Чему будет равна переменная «c» после выполнения этой программы:
  a = 20
  b = 3
  b = a % b
  c = a // (b + 1)

Вопрос 22

Определите значение переменной «a» после выполнения фрагмента программы:
  a = 10
  if a < 5:
    a += 12
  else:
    a -= 7

Вопрос 23

Определите значение переменной «a» после выполнения фрагмента программы:
  a = 10;
  if a > 5: a += 12
  else:     a -= 7
  if a > 5: a += 12
  else:     a -= 7

Вопрос 24

Определите значение переменной «a» после выполнения фрагмента программы:
  a = 10 
  b = 5
  if a > 1  or  a < b: 
    a -= 5
  if a > 1  and  a == b: 
    a -= 5

Вопрос 25

Какую логическую операцию нужно добавить в программу вместо многоточия, чтобы значение переменной «a» после выполнения фрагмента программы стало равно 3?
  a = 10
  b = 5
  if a < 1  ...  a > b: 
    a -= 7
  else:
    a += 7

Вопрос 26

Сколько раз будет выполнен этот цикл?
  i = 1
  while i < 3:
    print ( "Привет!" )
    i += 1

Вопрос 27

Какое число будет выведено на экран в результате выполнения этого цикла?
  i = 1
  print ( "9", end="" )
  while i < 3:
    print ( i, end="" ) 
    i += 1

Вопрос 28

Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?
  i = ...
  while i >= 2:
    print ( "Привет!" )
    i -= 1

Вопрос 29

Чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы?
  a = 10;
  for i in range(2):
    a -= 1

Вопрос 30

Какое число будет выведено на экран после выполнения этого фрагмента программы?
  for i in range(2,0,-1):
    print ( i, end="" )

Вопрос 31

Какое число будет выведено на экран после выполнения этого фрагмента программы?
  print ( 1, end="" )
  for i in range(2,2):
    print ( i, end="" )

Вопрос 32

Как называется число, которое указывает на конкретный элемент массива и записывается в квадратных скобках?

Вопрос 33

Какой индекс имеет последний элемент массива A?
  A = [8]*6

Вопрос 34

Требуется заполнить массив именно так: 
  X = [1 3 5 7 9 11]
Какой оператор надо поместить в тело цикла вместо многоточия?
  X = [0]*6
  for k in range(6):
     ...

Варианты ответов
  • X[k] = k
  • X[k] = 2*k
  • X[k] = 2*k - 1
  • X[k] = 2*k + 1
  • X[k] = 2*(k + 1)
Вопрос 35

Что надо написать вместо многоточия, чтобы вывести элементы массива X из N элементов в обратном порядке? В ответе не используйте пробелы.
  for k in range(N):
     print ( ... )

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт