Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  Проверочная работа по теме "Обработка строк на Паскаль"

Проверочная работа по теме "Обработка строк на Паскаль"

Avatar
08.05.2024. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Проверочная работа на знание и применение операторов для обработки символьных переменных

Список вопросов теста

Вопрос 1

Определите значение переменной k, после выполнения фрагмента программы:

n: = 'Самый лучший день';

k: = length (n);

write (k);

Вопрос 2

Определите результат работы следующего фрагмента программы:

n: = 'Обработка строк';

delete (n, 4, 10);

write (n);

Вопрос 3

Определите результат работы следующего фрагмента программы:

n: = 'Обработка строк в Паскаль';

insert ('оч', n, 8);

write (n);

Вопрос 4

Определите результат работы следующего фрагмента программы:

n: = 'В лесу родилась ёлочка, в лесу она росла.';

k: = copy (n, 19, 7);

write (k);

Вопрос 5

Определите результат работы следующего фрагмента программы:

n: = 'Ехали медведи на велосипеде';

k: = copy (n, 4, 1);

delete (n, 1, 18);

insert (k, n, 0);

delete (n, 3, 2);

write (n);

Вопрос 6

Определите значение переменной k, если

n: = 'Все дороги ведут в Москву';

for i: = 1 to length (n) do  if n[i] = 'в' then k:=k+1;

write (k);

Варианты ответов
  • 2
  • 3
  • 4
Вопрос 7

Определите результат работы следующего фрагмента программы:

n: = 'Обработка строк';

for i: = 1 to length (n) do if n[i] = 'р' then n[i]: = ' ';

write (n);

Вопрос 8

Определите начальные значения переменных a и b, если поле выполнения фрагмента программы программа вывела на экран “Привет! Как дела?” (без кавычек)?

c: = b + a;

insert (' Как ', c, 8);

write (c);

Варианты ответов
  • a='Привет! '
  • b='Привет! '
  • a=' дела?'
  • b='дела?'
  • a='дела?'
  • b=' дела?'
Вопрос 9

Что будет выведено на экран после выполнения программы?

var s: string; i: integer;

begin

s:='М';

for i: = 1 to 2 do s: = s + 'а';

s:=s+s;

write (s);

end.

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт