Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Проверочная работа. Паскаль. Условный оператор

Проверочная работа. Паскаль. Условный оператор

Avatar
29.01.2022. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
На выполнение работы отводится 15 минут. Внимательно читайте условия заданий

Список вопросов теста

Вопрос 1

Ниже приведена программа.

var s, t: integer;

begin

    readln(s);

    readln(t);

    if (s > 12) or (t > 12)

        then writeln(‘ДА’)

        else writeln(‘НЕТ’)

end.

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(1, 13); (14, 2); (1, 12); (11, 12); (–14, –14); (–11, 13); (–4, 11); (2, 9); (8, 6).

Сколько было запусков, при которых программа напечатала «ДА»?

Варианты ответов
  • 2
  • 3
  • 4
  • 5
Вопрос 2

Ниже приведена программа.

 var s, t: integer;

begin

    readln(s);

    readln(t);

    if (s > 8) or (t > 8)

        then writeln(‘ДА’)

        else writeln(‘НЕТ’)

end.

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

 (8, 8); (9, 6); (4, 7); (6, 6); (–9, –2); (–5, 9); (–10, 10); (6, 9); (10, 6).

 Сколько было запусков, при которых программа напечатала «НЕТ»?

Варианты ответов
  • 3
  • 4
  • 5
  • 6
Вопрос 3

Ниже приведена программа.

 var s, t: integer;

begin

    readln(s);

    readln(t);

    if (s > 8) and (t > 8)

        then writeln(‘ДА’)

        else writeln(‘НЕТ’)

end.

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

 (9, 10); (11, 5); (–2, 8); (9, 9); (2, 9); (–1, 3); (–4, 5); (10, 9); (4, –3).

 Сколько было запусков, при которых программа напечатала «ДА»? В ответе запиши число

Вопрос 4

Ниже приведена программа.

 var s, t: integer;

begin

    readln(s);

    readln(t);

    if (s > 10) and (t > 10)

        then writeln(‘ДА’)

        else writeln(‘НЕТ’)

end.

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

 (10, 10); (10, 6); (–4, 8); (2, 9); (12, 7); (–11, 4); (–8, 13); (10, 9); (11, 11).

Сколько было запусков, при которых программа напечатала «НЕТ»? В ответе запиши число

Вопрос 5

Ниже приведена программа.

 var s, k: integer;

begin

    readln(s);

    readln(k);

    if s div 2 = k

        then writeln(‘ДА’)

        else writeln(‘НЕТ’)

end.

Было проведено 9 запусков программы, при которых в качестве значений переменных s и k вводились следующие пары чисел:

 (1, 1); (8, 4); (16, 12); (25, 1); (7, 3); (10, 5); (10, 2); (4, 1); (2, 4).

Сколько было запусков, при которых программа напечатала «ДА»?

Варианты ответов
  • 1
  • 3
  • 5
  • 7
Вопрос 6

Ниже приведена программа.

 var s, k: integer;

begin

    readln(s);

    readln(k);

    if s mod 8 = k

        then writeln(‘ДА’)

        else writeln(‘НЕТ’)

end.

Было проведено 9 запусков программы, при которых в качестве значений переменных s и k вводились следующие пары чисел:

 (1, 1); (8, 4); (16, 12); (25, 1); (11, 3); (10, 5); (10, 2); (4, 1); (2, 5).

Сколько было запусков, при которых программа напечатала «ДА»?

Варианты ответов
  • 2
  • 3
  • 4
  • 5
Вопрос 7

Ниже приведена программа.

 var s, k: integer;

begin

    readln(s);

    readln(k);

    if s < > 2*k

        then writeln(‘ДА’)

        else writeln(‘НЕТ’)

end.

Было проведено 9 запусков программы, при которых в качестве значений переменных s и k вводились следующие пары чисел:

 (1, 2); (8, 4); (-6, -12); (-5, -5); (3, 11); (-10, 12); (-10, -5); (4, 1); (2, 5).

Сколько было запусков, при которых программа напечатала «ДА»? В ответе запишите число

Вопрос 8

Какое значение будет иметь переменная d после выполнения следующих операторов

a:=2; b:=3; d:=4; if a>b then d:=a else begin d:=b; d:=d+a end;

Варианты ответов
  • 2
  • 3
  • 5
  • 4
Вопрос 9

Какое значение будет иметь переменная v после выполнения следующих операторов

a:=5; k:=2; if a-k>0 then v:=a else v:=k; v:=v+4;

Варианты ответов
  • 2
  • 5
  • 6
  • 9
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт