Проверочная работа "Начало программирование в Паскале"
Список вопросов теста
Вопрос 1
Какая последовательность символов не может служить именем в языке Паскаль?
Варианты ответов
- maS1
- 2D
- _mas
- d2
Вопрос 2
Целые числа имеют тип данных:
Варианты ответов
- real
- integer
- boolean
- string
Вопрос 3
В программе на языке Паскаль обязательно должен быть:
Варианты ответов
- Заголовок программы
- Оператор присваивания
- Блок констант
- Программный блок
Вопрос 4
Описать переменную – это значит указать её:
Варианты ответов
- Тип и значение
- Имя и значение
- Имя и тип
- Имя, тип и значение
Вопрос 5
Для вывода результатов в Паскале используется оператор
Варианты ответов
- begin
- readln
- write
- var
Вопрос 6
Сколько раз будет выполнен цикл, записанный ниже:
fоr i:=0 tо 15 dо s:=s+l;
Ответ запишите числом.
Вопрос 7
Сколько раз будет выполнен цикл
k:=5;
fоr i:=k-l to k+1 dо s:=s+l;
Ответ запишите числом.
Вопрос 8
Дана программа
for А:= -3 to 7 do
write (А);
Какое значение будет иметь переменная А на третьем витке выполнения цикла?
Ответ запишите числом без пробелов
Вопрос 9
В программе «:=» обозначает оператор присваивания, знаки «+», «–», «*» и «/» – соответственно операции сложения, вычитания, умножения и деления. Правила выполнения операций и порядок действий соответствует правилам арифметики.
f := 21
е := 10
f := 5*f+5
е := f–10–е*5
В ответе укажите одно целое число — значение переменной e после выполнения алгоритма
Вопрос 10
Определите значение переменной С после выполнения следующего фрагмента программы:
а:= 100;
b:= 40;
a:= а–b*5;
if a>b then c:= a–b else с:= b–а;
Ответ запишите числом
Вопрос 11
Определите, что будет напечатано в результате работы следующей программы.
s := 0;
fоr k := 3 tо 10 dо
s := s + 13;
writеln(s);
Вопрос 12
Запишите значение переменной u, полученное в результате работы следующей программы.
u := 30;
fоr i := 1 tо 6 dо
u := u − i;
writеln (u);