Меню
Тесты
Тесты  /  Информатика  /  11 класс  /  Промежуточный тест "Язык программирования Python"

Промежуточный тест "Язык программирования Python"

Avatar
12.12.2024. Тест. Информатика, 11 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тест - промежуточная проверка знаний перед итоговой контрольной работой 1 попытка. 40 минут

Список вопросов теста

Вопрос 1

Что выведет на экран этот код?

k=0
for i in range (1,5):

    if i % 2 == 0:

        k+=1

print(k)

Варианты ответов
  • 2
  • 1
  • 5
  • 2 и 4
Вопрос 2

Напишите, какой индекс имеет последний элемент массива В = [10]*9?

Варианты ответов
  • 9
  • 10
  • 8
  • 0
Вопрос 3

Требуется заполнить одномерный массив именно так: C = [ -9, -6, -3, 0, 3]

Какой оператор надо поместить в тело цикла вместо многоточия?

            C = [0]*6

            for k in range(1,6):

            ...

Варианты ответов
  • C[k] = k + 3
  • C[k] = 12 - 2*k
  • C[k] = 3*(k+1) + 9
  • C[k] = 3*k - 12
  • C[k] = 12 - 3*k
Вопрос 4

Выберите фрагмент программы, заполняющий массив из 12 элементов случайными числами в диапазоне [6;17]

Варианты ответов
  • N = 12 A = [ randint (6,17) for x in range(N)]
  • N = 6 A = [ randint(17) for x in range(N)]
  • N = 12 A = [ randint for x in range(6,17)]
Вопрос 5

Как можно вывести одномерный массив на экран? Укажите  все возможные варианты

Варианты ответов
  • print ( A )
  • for i in range(N): print ( A[i], end = " " )
  • A[i] = int(input())
  • for x in A: print(x, end = " " )
  • for i in range(N): A[i] = int(input())
Вопрос 6

Что делает следующий фрагмент программы?

B = [ x for x in A ]   if 180 < x < 190]

print ( sum(B)/len(B) )

Варианты ответов
  • Считает среднее арифметическое чисел от 180 до 190
  • Считает сумму чисел от 180 до 190
  • Выводит на экран числа от 180 до 190
  • Заполняет массив А числами от 180 до 190
Вопрос 7

Определите, при каком наибольшем введённом значении переменной s программа выведет число 128. 

s = int(input())
n = 4
while s < 37:
    s = s + 3
    n = n * 2
print(n)

Вопрос 8

Определите, что будет выведено на экран после выполнения следующего фрагмента программы:

k = 6

for i in range (0,4,1):

        print( k+i**2, end=" " )

        k -= 1

Варианты ответов
  • 12 8 6 6
  • 6 6 8 12
  • 6 8 12
Вопрос 9

Определите, сколько существует различных целых значений переменной s, при вводе которых данная программа выведет число 256.

s = int(input())
s = 3 * (s // 10)
n = 1
while s < 221:
    s = s + 13
    n = n * 2
print(n)

Вопрос 10

Определите, при каком наибольшем введённом значении переменной s программа выведет число 60.

s = int(input())
s = (s + 1) // 7
n = 36
while s < 2050:
    s = s * 2
    n = n + 3
print(n)

Вопрос 11

В двумерном массиве для  элементов главной диагонали выполняется равенство: 

Варианты ответов
  • i=j
  • i+j=N-1
  • i+j=N+1
  • i+j=N
Вопрос 12

В двумерном массиве для  элементов побочной диагонали выполняется равенство: 

Варианты ответов
  • i=j
  • i+j=N-1
  • i+j=N+1
  • i+j=N
Вопрос 13

Выберите правильный вариант создания нулевой матрицы размером N*M : 

Варианты ответов
  • N = 3 M = 2 X = [0]*M Y = [X]*N
  • N = 3 M = 2 Y = [X]*N X = [Y]*M
  • A = [] for i in range(N): A.append ( [0]*M )
  • A = [] for i in range(N): A.append ( N*M )
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт