Программирование на языке Паскаль
Список вопросов теста
Вопрос 1
С какого слова обычно начинается раздел операторов?
Варианты ответов
- uses
- begin
- var
- write
Вопрос 2
Какая из переменных не может является целой ?
Варианты ответов
- a:=2;
- c:=-25;
- b:=4 div 7;
- d:=d / 6;
Вопрос 3
Выделите верные утверждения. Чем отличаются команды Write(a); и Writeln(a) ?
Варианты ответов
- после выполнения Write(a) курсор не переводится на начало новой строки
- после выполнения Writeln(a) курсор переводится на начало новой строки
- после выполнения Write(a) курсор переводится на начало новой строки
- нет правильного
Вопрос 4
Операция Div позволяет найти...
Варианты ответов
- результат деления одного числа на другое
- найти результат целочисленного деления одного числа на другое
- остаток от целочисленного деления
- Нет правильного
Вопрос 5
Какое значение получит переменная a после выполнения серии команд
a:=5;
b:=2;
a:=b * a - SQR(a) ;
Варианты ответов
- -15
- 15
- 40
- 10
Вопрос 6
Что будет выведено на экран после выполнения серии команд
a:=5;
b:=3;
a:=b-a mod 4;
write(`a=`,a);
Варианты ответов
- 2
- а=2
- а=1
- 1
Вопрос 7
Что будет выведено на экран после выполнения серии команд
a:=-5;
b:=2;
a:=b-a div 3;
write(a);
Варианты ответов
- 1
- 2
- 3
- 4
Вопрос 8
Что будет выведено на экран после выполнения серии команд
a:=4;
b:=8;
a:=a / b - 5;
write(a);
Варианты ответов
- 4,5
- 4,75
- 5,25
- -4,5
Вопрос 9
Переменная а является целой. В какой строке при использовании команды присвоить значение допущена ошибка ?
Варианты ответов
- a:=SQRT(a);
- a:=sqr(5);
- a:=a / 5-1;
- a:=abs(2*a);
Вопрос 10
Что означает в Паскале точка с запятой
Варианты ответов
- Конец цикла;
- Конец строки программы;
- Отделяет операторы друг от друга;
- Конец программы;
Вопрос 11
Каким служебным словом описываются дробные переменные:
Варианты ответов
- INTEGER;
- REAL;
- CHAR;
- STRING:
Вопрос 12
Раздел описаний VAR используется для описания:
Варианты ответов
- Констант;
- Меток;
- Функций;
- Переменных;
Вопрос 13
Чем заканчивается программа?
Варианты ответов
- END.
- Program
- Readln
Вопрос 14
Укажите операторы вывода?
Варианты ответов
- Writeln ()
- Write ()
- Readln ()
- Readkey ()
Вопрос 15
Что означает знак := в языке программирования ПАСКАЛЬ?
Варианты ответов
- Присваивание;
- Деление;
- Равенство;
- Сравнение;
Вопрос 16
Какое значение будет иметь переменная b после выполнения следующего фрагмента программы
a:=4;
b:=2;
a:=a*a*b;
b:=a+b;:
Варианты ответов
- 38
- 34
- 16
- 18
Вопрос 17
Чему равно значение выражения:
sqrt(16)*2 - sqr(3)-20/5
Варианты ответов
- -5
- -6
- 5
- 6
Вопрос 18
Запишите значение переменной s, полученное в результате работы следующей программы.
Var s,k: integer;
Begin
s := 0;
for k := 3 to 7 do
s := s + 6;
writeln(s);
End.
Варианты ответов
- 24
- 36
- 30
- 16
Вопрос 19
Укажите оператор ветвления:
Варианты ответов
- For
- If
- While
- Repeat
Вопрос 20
Укажите оператор цикла с известным число повторений:
Варианты ответов
- IF
- FOR
- WHILE
- REPEAT
- BEGIN


