Программирование массивов
Список вопросов теста
Вопрос 1
Что называется массивом?
Варианты ответов
- Под массивом понимается совокупность конечного числа данных различных типов;
- Под массивом понимается совокупность конечного числа данных одного типа;
- Под массивом понимается совокупность бесконечного числа данных одного типа;
Вопрос 2
Укажите правильное описание массива
Варианты ответов
- Var a:array[1..1000] of integer;
- Var А, В, С: ARRAY [1..50] OF REAL or INTEGER;
- Var А: ARRAY [1..50 OF REAL];
Вопрос 3
Индексом элемента называется…
Варианты ответов
- Номер элемента в массиве
- Последний элемент в массиве
- Значение элемента массива
Вопрос 4
Для заполнения массива случайными числами мы должны подключить датчик случайных чисел, используя команду…
Варианты ответов
- read
- Randomize;
- A[i]:=?;
- Clrscr;
Вопрос 5
В записи D[4]=3, D обозначает…
Варианты ответов
- Обозначение типа
- Имя ячейки
- Имя массива
Вопрос 6
Что выполняет следующий фрагмент программы: For i:=1 to N do write (a[ i ], ‘ ’);
Варианты ответов
- Выполняет проверку значений элементов массива
- Производит ввод данных в массив
- Выводит N значений массива на экран
Вопрос 7
Чему равна сумма элементов a[1] и a[4]массива, сформированного следующим образом?
For i:=1 to 5 do a[i]:=i*(i+1);
Варианты ответов
- 30
- 40
- 5
- 22
Вопрос 8
Числовой массив А заполнен последовательно числами: 7, 15, 87, 34. Укажите значение элемента А[2].
Варианты ответов
- 34
- 87
- 15
- 7
Вопрос 9
Выберите способ объявления в программе массива М, состоящего из 30 вещественных чисел.
Варианты ответов
- Var m:array[1..30] of real;
- Var m:array[1..30] of integer;
- Var m:array[1..300] of real;
- Var m:array[10..39] of integer;
Вопрос 10
Какими способами можно заполнить массив?
Варианты ответов
- по формуле
- случайным образом
- ввод с помощью клавиатуры
- с помощью сканера
Вопрос 11
Дан фрагмент программы для заполнения одномерного массива A с помощью ввода данных с клавиатуры. В какой строке текста программы допущена ошибка?
1 for i:=1 to n do begin
2 write(`a[`,i,`]=?`);
3 readln(a);
4 end;
Варианты ответов
- 1
- 2
- 3
- 4
Вопрос 12
Выберите правильные варианты вывода элементов массива на печать в строку.
Варианты ответов
- for i:=1 to n do writeln(a[i]);
- for i:=1 to n do write(a[i],` ` );
- for i:=1 to n do write(`a[`,i,`]=`);
- for i:=1 to n do write(` a`,i,`=`,a[i]);


