Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  8.3.4 Pascal. Цикл FOR.

8.3.4 Pascal. Цикл FOR.

Avatar
14.10.2017. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.

8 класс.Pascal. Цикл FOR. 15 вопросов. Ограничение по времени 20 минут.

Список вопросов теста

Вопрос 1

Назначение циклической структуры:

Варианты ответов
  • повторение одной команды не более 10 раз
  • повторение идущих подряд одинаковых команд некоторое число раз
  • проверка условия в тексте
  • печать текста
Вопрос 2

Тело цикла - это...

Варианты ответов
  • группа команд, не входящих в циклическую структуру
  • произвольный текст
  • произвольная группа команд
  • группа команд, повторяющихся некоторое число раз
Вопрос 3

Укажите, сколько раз выполнится тело цикла с заданным заголовком:
FOR I: = -1 TO 2 DO

Вопрос 4

Определите значение переменной S после выполнения программы:
VAR A,S: INTEGER;
BEGIN
S:=0;
FOR A:=1 TO 4 DO
S:=S+A;
WRITELN('S=', S);
END.

Вопрос 5

Какой из перечисленных заголовков циклов не содержит ошибок и цикл выполнится хотя бы один раз

Варианты ответов
  • FOR K := 1 TO 5.5 DO
  • FOR J := 10 TO - 2 DO
  • FOR X := 3 TO 12 DO
  • FOR Y = 0 TO 7 DO
Вопрос 6

Определите значение переменной S после выполнения программы:
VAR A,S: INTEGER;
BEGIN
S:=0;
FOR A:=1 TO 4 DO
S:=S*A;
WRITELN('S=', S);
END.

Вопрос 7

Что является назначением представленного фрагмента программы:
S:=0;
FOR K:=1 TO 10 DO S:=S+K;

Варианты ответов
  • Вычисление десятой степени числа K
  • Вычисление суммы десяти чисел, введенных пользователем
  • Вычисление суммы первых десяти натуральных чисел
Вопрос 8

Что является назначением представленного фрагмента программы:
S:=1;
FOR K:=1 TO 100 DO S:=S*K;

Варианты ответов
  • Вычисление сотой степени числа K
  • Вычисление произведения первых ста натуральных чисел
  • Вычисление произведения ста чисел, введенных пользователем
Вопрос 9

Определите значение переменной S после выполнения программы:
VAR A,S: INTEGER;
BEGIN
S:=1;
FOR A:=1 DOWNTO -2 DO
S:=S*2;
WRITELN('S=', S);
END.

Вопрос 10

Определите значение переменной S после выполнения программы:
VAR A,S: INTEGER;
BEGIN
S:=0;
FOR A:=1 TO 3 DO
S:=S+А*2;
WRITELN('S=', S);
END.

Вопрос 11

В записи
FOR A:=1 TO 3 DO
S:=S+А*2;
запись
FOR A:=1 TO 3 DO
означает
 

Варианты ответов
  • тело цикла
  • заголовок цикла
  • выполняемый цикл
  • выполняемые действия
Вопрос 12

В записи
FOR A:=1 TO 3 DO
S:=S+А*2;
запись
S:=S+А*2;
означает

Варианты ответов
  • заголовок цикла
  • тело цикла
  • выполняемый цикл
  • выполняемые действия
Вопрос 13

Укажите, сколько раз выполнится тело цикла с заданным заголовком:
FOR I: = 4 TO 2 DO

Вопрос 14

Укажите, сколько раз выполнится тело цикла с заданным заголовком:
FOR I: = 6 DOWNTO 2 DO

Вопрос 15

Укажите, сколько раз выполнится тело цикла с заданным заголовком:
FOR I: = 6 DOWNTO 6 DO

Пройти тест
Сохранить у себя:

Комментарии 1

Чтобы добавить комментарий зарегистрируйтесь или на сайт

Пользователь, 04.11.2017 15:59

как посмотреть ответы к тесту?

не показывает ошибки которые я сделал