Pascal abc
Список вопросов теста
Вопрос 1
Для чего предназначен оператор Readln (a)?
Варианты ответов
- для ввода данных с клавиатуры;
- для ввода символьных данных;
- для печати результатов на принтере
- для вывода на экран
Вопрос 2
Определите результат работы программы:
Writeln (‘5 + 5 =’, 5 + 5)
Варианты ответов
- 10 = 10
- 5 + 5 = 10
- 20
- 5+ 5 = 5 + 5
Вопрос 3
Определите результат работы программы:
a := - 6;
b := - 5;
a := a + 2 * b;
b := a;
Writeln (a,b).
Варианты ответов
- 0, - 16
- – 16, 0
- – 16, - 16
- – 6, - 5
Вопрос 4
С какого служебного слова начинается программа:
Варианты ответов
- Var
- Program
- Begin
- End
Вопрос 5
Что делает эта программа?
Program Example;
Var a, b, S: Integer;
Begin
Writeln (‘Введите 2 числа’);
Readln (a,b);
S:=a*b;
Writeln (S);
Readln;
End.
Варианты ответов
- находит периметр квадрата
- находит площадь квадрата
- находит площадь прямоугольника
- находит площадь круга
Вопрос 6
Сколько данных нужно ввести для вычисления площади квадрата?
Варианты ответов
- одно
- два
- три
- четыре
Вопрос 7
Для чего предназначен оператор Writeln?
Варианты ответов
- для ввода данных с клавиатуры
- для ввода числовых данных
- для печати результатов на принтере
- для вывода на экран
Вопрос 8
Определите результат работы программы:
Writeln (‘сумма= ‘, 5 + 5).
Варианты ответов
- 10
- сумма = 0
- сумма = 10
- сумма = 5 + 5
Вопрос 9
Сколько чисел необходимо ввести для вычисления площади прямоугольника?
Варианты ответов
- одно
- два
- три
- четыре
Вопрос 10
С какого служебного слова начинается раздел операторов:
Варианты ответов
- Var
- Program
- Begin
- End
Вопрос 11
- Что делает эта программа?
Program Example;
Var a, b, S: Integer;
Begin
Writeln (‘Введите 2 числа’);
Readln (a,b);
S:=2*(a+b);
Writeln (S);
Readln;
End.
Варианты ответов
- находит периметр прямоугольника
- находит площадь квадрата
- находит площадь прямоугольника
- находит площадь круга
Вопрос 12
Определите результат работы программы:
A:= -5;
B:= - 6;
A:=B;
B:=A;
Writeln (A,B);
Варианты ответов
- 0,0
- –6, -5
- –6, -6
- 0, -6
Вопрос 13
Как будут выведены значения Writeln (F, G)?
Варианты ответов
- через пробел
- через запятую
- через табулятор
- на разных строчках
Вопрос 14
С какого служебного слова начинается раздел описаний:
Варианты ответов
- Var
- Program
- Begin
- End
Вопрос 15
Определите результат работы программы:
a := - 5;
b:= - 6;
a := a - 2 * b;
b := a;
Writeln (a,b).
Варианты ответов
- 0, - 7
- 7, 7
- – 7, 0
- – 7, - 7
Вопрос 16
Оператор присваивания имеет вид:
Варианты ответов
- :=
- =
- =:
- верного ответа нет
Вопрос 17
Укажите целочисленный тип данных:
Варианты ответов
- Integer
- Real
- String
- Char
Вопрос 18
Укажите вещественный тип данных:
Варианты ответов
- Integer
- Real
- String
- Char
Вопрос 19
Какого раздела не существует в программе, написанной на языке Паскаль?
a. Заголовка;
b. Примечания;
c. Описаний;
d. Операторов;
Варианты ответов
- Примечания
- Описаний
- Операторов
- Заголовка
Вопрос 20
Где перечисляются все переменные, используемые в программе?
Варианты ответов
- В заголовке программы после слова Program
- После служебного слова uses
- В разделе описания переменных – после слова var
- В теле программы, между служебными словами begin и end


