Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  Описание массива

Описание массива

Avatar
05.12.2021. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Проверка знаний об основных понятиях массивов на начальном этапе

Список вопросов теста

Вопрос 1

Массив - это ... 

Варианты ответов
  • обозначаемая одним именем последовательность однотипных элементов
  • конечное число одинаковых величин
  • элементы, которые размещаются друг за другом
  • максимальное возможное количество элементов
Вопрос 2

Размер массива - это ... 

Варианты ответов
  • максимально возможное количество элементов в массиве
  • длина массива
  • минимально возможное количество элементов в массиве
  • количество положительных элементов в массиве
Вопрос 3

Сформирован массив из 10 случайных целых чисел:

var A: array [1..10] of integer; i: integer;

begin

for i:=1 to 10 do A[i]:=random(2,31);

Какому промежутку принадлежат числа из которого функция random случайным образом их генерировала для заполнения данного массива?

Варианты ответов
  • от 1 до 30
  • от 2 до 31
  • от 0 до 32
Вопрос 4

Какая группа операторов заполняет массив из 7 случайных целых чисел, принадлежащих промежутку [10; 30]?

Варианты ответов
  • for i : =1 to 7 do X [ i ]: = random (20) + 10;
  • for i : =1 to 7 do X [ i ]: = random (21) - 10;
  • for i : =1 to 7 do X [ i ]: = random (10,30);
  • for i : =1 to 7 do X [ i ]: = random (0,30);
Вопрос 5

Чему равен размер массива, описанного следующим образом:

var Room: array [3..13] of integer ?

Варианты ответов
  • 13
  • 10
  • 11
  • 3
Вопрос 6

Сколько элементов имеет массив, имеющий следующее описание:

var Name: array [7..31] of integer ?

Варианты ответов
  • 25
  • 24
  • 31
  • 26
Вопрос 7

В классе 30 учеников. Известен рост каждого в сантиметрах.

Для хранения значений роста можно использовать массив ROST, состоящий из 30 целых чисел. Как будет выглядеть описание этого массива?

Варианты ответов
  • Var ROST: array [1..30] of real;
  • Var: ROST: array [1..30] of integer;
  • Const n1=1; n2=30; Var ROST: array [n1..n2] of integer;
  • Var ROST: array [1,30] of integer;
  • Const n1=1; n2=30; Var ROST: array [n2..n1] of integer;
  • Var ROST: array [1..30] of integer;
Вопрос 8

Определите значение переменной S, которая высчитывается по формуле:

s:=A[1]-A[8];

Вопрос 9

Определите значение переменной S, которая высчитывается по формуле:

S:=A[5]*A12;

Вопрос 10

Дан массив D:array[1..15] of real;

Запишите команду присваивания для заполнения массива случайными числами от -5 до 5

Ответ вводите без пробелов.

Вопрос 11

Заполните пропуски в описании массива из 7 целых элементов:

Var a:array[2..  ] of integer;

Вопрос 12

Дан массив следующим описанием: var A:array[1..15] of real;

С помощью присваивания запишите команду заполнения массива случайными числами от 0 до 51.

Ответ вводите без пробелов

Вопрос 13

Задан массив, который описывается следующим образом:

C:  array [1..15] of integer;

Для заданного массива запишите без пробелов команду присваивания элементу с индексом 3 значение суммы элементов с индексами 7 и 4.

Ввод выполняйте без пробелов

 

Вопрос 14

Запишите без пробелов пропущенную команду в данной программе, вычисления суммы элементов массива.

var A:array [1..50] of integer; s: integer;
begin
 for var i:=1 to 7 do
 begin
  a[i]=random (30);
 end;
 ...
 for var i:=1 to 7 do
  s:=s+a[i];
 writeln (s);
end. 

Вопрос 15

Укажите верный порядок следования команд в данном участке программы для нахождения суммы элементов массива.

Варианты ответов
  • s:=0;
  • for i:=1 to 15 do
  • s:=s+a[i];
  • write('Сумма чисел равна ',s);
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт