Одномерные массивы 1 вариант
Список вопросов теста
Вопрос 1
Что является результатом этапа "формализация" решения задачи на компьютере?
Варианты ответов
- словесная информационная модель
- математическая модель
- алгоритм
- программа
Вопрос 2
Имеется описание:
var c:array[0..20] of integer;
Для хранения массива с будет отведено ... ячеек.
Варианты ответов
- 21
- 20
- 19
- 40
- 39
Вопрос 3
Чему равна сумма значений элементов массива a[1] и a[4], сформированного следующим образом?
for i:=1 to 5 do a[i]:=i*(i+1)
Варианты ответов
- 30
- 5
- 22
- 40
Вопрос 4
В таблице Dat представлены данные о количестве голосов, поданных за 10 исполнителей народных песен (Dat[1] - количество голосов, поданных за первого исполнителя; Dat[2] - за второго и т. д.).
Определите, какое число будет напечатано в результате работы следующей программы.
Var k, m: integer;
Dat: array[1..10] of integer;
Begin
Dat[1] = 16, Dat[2] = 20
Dat[3] = 20, Dat[4] = 41
Dat[5] = 14, Dat[6] = 21
Dat[7] = 28, Dat[8] = 12
Dat[9] = 15, Dat[10] = 35
m := 0
for k := 1 to 10 do
if Dat[k]>m then begin
m := Dat[k]
end
writeln(m)
End.
Варианты ответов
- 41
- 35
- 40
- 42
Вопрос 5
В таблице Ves хранятся данные о весе в килограммах по группе учащихся спортивной школы (Ves[1] - вес первого учащегося, Ves[2] - вес второго учащегося и т. д.). Определите, что будет напечатано в результате выполнения следующего алгоритма.
var Ves: array[1..14] of integer;
i, n: integer;
begin
Ves[1] = 25, Ves[2] = 21
Ves[3] = 23, Ves[4] = 28
Ves[5] = 30, Ves[6] = 25
Ves[7] = 31, Ves[8] = 28
Ves[9] = 25, Ves[10] = 28
Ves[11] = 30, Ves[12] = 27
Ves[13] = 26, Ves[14] = 24
n := Ves[1];
for i := 1 to 14 do begin
if Ves[i] < n then
n := Ves[i];
end;
writeln(n);
end.
Варианты ответов
- 20
- 30
- 31
- 21
Вопрос 6
В таблице Ves хранятся данные о весе в килограммах по группе учащихся спортивной школы (Ves[1] - вес первого учащегося, Ves[2] - вес второго учащегося и т. д.). Определите, что будет напечатано в результате выполнения следующего алгоритма.
var Ves: array[1..14] of integer;
i, n: integer;
begin
Ves[1] = 25, Ves[2] = 21
Ves[3] = 23, Ves[4] = 28
Ves[5] = 30, Ves[6] = 25
Ves[7] = 31, Ves[8] = 28
Ves[9] = 25, Ves[10] = 28
Ves[11] = 30, Ves[12] = 27
Ves[13] = 26, Ves[14] = 24
n := 0
for i := 1 to 14 do begin
if Ves[i] > 26 then
n := n + 1
end;
writeln(n)
end.
Варианты ответов
- 6
- 7
- 8
- 9
Вопрос 7
В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] - второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
Var k, m: integer;
Dat: array[1..10] of integer;
Begin
Dat[1] := 7, Dat[2] = 9,
Dat[3] := 10, Dat[4] := 5,
Dat[5] := 6, Dat[6] := 7
Dat[7] := 9, Dat[8] := 8
Dat[9] := 6;,Dat[10] := 9
m := 0;
for k := 1 to 10 do
if Dat[k] >8 then begin
m := m + Dat[k]
end;
writeln(m)
End.
Варианты ответов
- 10
- 25
- 37
- 45
Вопрос 8
Для получения случайных чисел из промежутка [0;6] используют следующую функцию:
Варианты ответов
- Random (6)
- Random (7)
- Random (7)+6
- Random (10)-4
Вопрос 9
Что производит следующий фрагмент программы?
for i:=1 to n do writeln(a[i]);
Варианты ответов
- Ввод элементов массива с клавиатуры.
- Вывод элементов массива на экран монитора в строку.
- Вывод элементов массива на экран монитора в столбец
- Ввод элементов массива из файла.
Вопрос 10
Дана программа:
Program E2_1;
Var a: Array [1..8] Of Integer;
M, k: Integer;
Begin
For k := 1 To 8 Do Readln (a[k]);
M := a[1];
For k := 2 To 8 Do
If M < a[k] Then M := a[k];
Write (M)
End.
Сколько раз будет выполнен оператор M := a[k] при заданном массиве (3, 8, 7, 9, 4, 10, 2, 12)?
Варианты ответов
- 3
- 4
- 5
- 6
Вопрос 11
При наборе программы вычисления суммы отрицательных элементов массива
Program E2_2;
Var a: Array [1..8] Of Integer;
s, k: Integer;
Begin
For k := 1 To 8 Do Readln (a[k]);
s := 0;
For k := 1 To 8 Do
If a[k] < 0 Then s := s + a[k];
Writeln (s)
End
в записи оператора s := s + a[k] была допущена ошибка - вместо него был записан оператор s := s + 1. Каким оказался ответ после исполнения неверной программы, если в качестве элементов массива были введены числа: -1, 3, -2, 4, -5, 6, -7, 8?
Варианты ответов
- 4
- -4
- 0
- 8
Вопрос 12
Какие значения примут элементы массива A[3] и A[4] после выполнения последовательности операторов, если первоначально
A[3] := 5;
A[4] := 6;
A[3] = A[4];
A[4] := A[3]?
Варианты ответов
- A[3] = 6; A[4] = 6;
- A[3] = 6; A[4] = 5;
- A[3] = 5; A[4] = 6;
- A[3] = 2; A[4] = 3;
Вопрос 13
Что такое массив?
Варианты ответов
- это простой тип данных, состоящий из одного элемента
- это структурированный тип данных, состоящий из элементов разных типов
- это структурированный тип данных, состоящий из элементов одного типа, упорядоченных по номеру и объединенных под одним именем
- это совокупность данных, объединенных под одним именем
Вопрос 14
В таблице Tur хранятся данные о количестве ребят, ходивших в поход вместе с туристическим клубом "Полянка". (Tur[l] - число ребят в 2001 году, Tur[2] - в 2002 году и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
Var k, m: integer;
Tur: array[1..11] of integer;
Begin
Tur[1] := 1; Tur[2] := 11;
Tur[3] := 8; Tur[4] := 12;
Tur[5] := 5; Tur[6] := 6;
Tur[7] := 15; Tur[8] := 16;
Tur[9] := 16; Tur[10] := 21;
Tur[11] := 7;
m := 0;
For k := 1 to 11 Do
If Tur[k] < 10 Then Begin
m := m + Tur[k];
End;
Writeln(m);
End.
Варианты ответов
- 5
- 27
- 25
- 6
Вопрос 15
В таблице Dat хранятся данные измерений среднесуточной морской воды в градусах (Dat[1] - данные за первый день, Dat[2] - за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
var Dat: array[1..7] of integer;
k, day: integer;
begin
Dat[1] := 19; Dat[2] := 21;
Dat[3] := 20; Dat[4] := 23;
Dat[5] := 24; Dat[6] := 25;
Dat[7] := 23;
day := Dat[1];
for k := 1 to 7 do begin
if Dat[k] > day then
day := Dat[k]
end;
writeln(day);
end.
Варианты ответов
- 25
- 24
- 20
- 26


