Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Одномерные массивы №2

Одномерные массивы №2

Avatar
16.12.2021. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Одномерный массив — это фиксированное количество элементов одного и того же типа, объединенных одним именем, где каждый элемент имеет свой номер. Обращение к элементам массива осуществляется с помощью указания имени массива и номеров элементов.

Список вопросов теста

Вопрос 1

Чему равно значение элемента a[3] массива, сформированного следующим образом?

For i:=1 to 5 do a[i]:=i*(i+1)

Варианты ответов
  • 12
  • 20
  • 10
Вопрос 2

Чему равна сумма элементов массива a[2] и a[4], сформированного следующим образом?

For i:=1 to 5 do a[i]:=8*(i+2*3)

Варианты ответов
  • 102
  • 144
  • 148
Вопрос 3

Массив описан следующим образом:

const b:array [1..5] of integer=(1, 7, 3, 2, 9);

значение выражения b[4]*b[1]+b[5]*b[2] = 

Варианты ответов
  • 59
  • 65
  • 55
Вопрос 4

Определите, что будет напечатано в результате работы следующей программы:

var s,n:integer;

begin

s:=2;

for n:=2 to 5 do s:=s+n*2;

write (s);

end.

Варианты ответов
  • 30
  • 25
  • 32
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт