Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Тренировочный тест ОГЭ по информатике

Тренировочный тест ОГЭ по информатике

Avatar
22.12.2021. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тренировочный тест по информатике проверяет знание первых 10 заданий ОГЭ по информатике. Время выполнения теста 40 минут. Задания взяты из банка ФИПИ, решу ОГЭ, с сайта К.Ю.Полякова

Список вопросов теста

Вопрос 1

В одной из кодировок Unicode каждый символ кодируется 16 битами. Вова написал текст (в нём нет лишних пробелов):

  «Собака, кошка, курица, корова, лошадь, коза, 
   овца – домашние животные».

Затем он добавил в список название ещё одного животного. Заодно он добавил необходимые запятые и пробелы. При этом размер нового предложения в данной кодировке оказался на 12 байт больше, чем размер исходного предложения. Напишите в ответе длину добавленного названия животного в символах.

Вопрос 2

От разведчика была получена следующая шифрованная радиограмма, переданная с использованием азбуки Морзе:

• • − • • • − • − − • − − • • − −

При передаче радиограммы было потеряно разбиение на буквы, но известно, что в радиограмме использовались только следующие буквы:

Т А У Ж Х
• − • • − • • • − • • • •

Определите текст радиограммы. В ответе укажите, сколько букв было в исходной радиограмме.

Вопрос 3

Найдите количество двухзначных натуральных чисел X, для которых ложно высказывание:

  (X >= 47) И НЕ ((X кратно 4) И НЕ (Х кратно 8))
Вопрос 4

Между населёнными пунктами A, B, C, D, E построены дороги, протяжённость которых (в километрах) приведена в таблице.

 

A

B

C

D

E

A

 

4

2

 

8

B

4

 

7

 

 

C

2

7

 

2

6

D

 

 

2

 

3

E

8

 

6

3

 

Определите длину кратчайшего пути между пунктами B и E. Передвигаться можно только по дорогам, протяжённость которых указана в таблице. Каждый пункт можно посетить только один раз.

Вопрос 5

У исполнителя Квадратор две команды, которым присвоены номера:

1.  прибавь 1

2.  возведи в квадрат

Первая из них увеличивает число на экране на 1, вторая возводит его во вторую степень.

Составьте алгоритм получения из числа 3 числа 84, содержащий не более 5 команд. В ответе запишите только номера команд.

 

(Например, 11221  — это алгоритм:

прибавь 1

прибавь 1

возведи в квадрат

возведи в квадрат

прибавь 1,

который преобразует число 1 в 82.)

 

Если таких алгоритмов более одного, то запишите любой из них.

Вопрос 6

Дана программа:

Python

Паскаль

  s = int(input())
  t = int(input())
  A = int(input())
  if s < A and t < 5:
    print("ДА")
  else:
    print("НЕТ")

  var s, t, A: integer;
  begin
    readln(s);
    readln(t);
    readln(A);
    if (s < A) and (t < 5)
      then writeln('ДА')
      else writeln('НЕТ')
  end.

Было проведено 9 запусков этой программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

  (10, 15); (-6, -3); (11, 5); (8, -8); (4, -11);
  (12, 5), (-11, -8), (15, 0), (10, 7)

Сколько существует целых значений параметра А, при котором для указанных входных данных программа напечатает «НЕТ» 7 раз.

Вопрос 7

Доступ к файлу name.gif, находящемуся на сервере jour.com, осуществляется по протоколу ftp. Фрагменты адреса файла закодированы буквами от А до Ж. Запишите последовательность этих букв, кодирующую адрес указанного файла в сети Интернет.

 

A)  .com

Б)  ftp

B)  jour

Г)  /

Д)  ://

Е)  .gif

Ж)  name

Вопрос 8

Ниже приведены запросы и количество страниц, которые нашел поисковый сервер по этим запросам в некотором сегменте Интернета:

  Москва & (Париж | Лондон)  427
  Москва & Париж             222
  Москва & Париж & Лондон    50

Сколько страниц будет найдено по запросу

  Москва & Лондон
Вопрос 9

На рисунке – схема дорог, связывающих населённые пункты A, B, C, D, E, F, G. По каждой дороге можно двигаться только в одном направлении, указанном стрелкой. Сколько существует различных путей из населённого пункта А в населённый пункт G?


Вопрос 10

Найдите значение выражения:

    10102 + 178 + 1С16 

Ответ запишите в восьмеричной системе счисления.

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт