Одномерные массивы
Список вопросов теста
Вопрос 1
Массив описан следующим образом:
var b:array[1..5] of integer=(1, 2, 3, 5, 11);
Чему равно значение выражения b[5]*b[4] - b[2] - b[3]*b[1] ?
Варианты ответов
- 15
- 11
- 22
- 50
Вопрос 2
Обращение к элементу массива осуществляется по его:
Варианты ответов
- индексу
- имени и индексу
- имени
- нет верных ответов
Вопрос 3
Укажите правильное описание одномерного массива целых чисел.
Варианты ответов
- Var a: array[1...10] of integer;
- Var a: arrey[1..10] of integer;
- var а: array [1..10] of real;
- var а: array [1..10] of integer;
Вопрос 4
Укажите фрагмент программы заполнения целочисленного массива А десятью случайными числами из интервала [0, 10]
Варианты ответов
- for i:=1 to 10 do a[i]:=random(10);
- for i:=1 to 10 do a[i]:=random(11);
- for i:=1 to 10 do a[i]:=random(9)+1;
- for i:=1 to 9 do a[i]:=random(11)−1;
Вопрос 5
Определите способ заполнения массива.
for i:=1 to 5 do a[i]:=i;
Варианты ответов
- с помощью оператора присваивания
- с помощью оператора ввода с клавиатуры
- случайными числами от 1 до 5
- нет верного ответа
Вопрос 6
Дан фрагмент программы заполнения целочисленного массива А
for i:=1 to 5 do
begin
A[2*i-1]:=i;
A[2*i]:=i*i
end;
Чему равен элемент массива A[5]?
Варианты ответов
- 3
- 5
- 9
- 25
Вопрос 7
Какое значение примет переменная S в результате выполнения фрагмента программы:
var
s: integer;
с: array [1..3] of integer;
const а: array [1..3] of integer=(1, 2, 3);
const b: array [1..3] of integer=(3, 2, 0);
begin
s:=0;
for i:=1 to 3 do
begin
c[i]:=a[i]+b[i];
s:=s+c[i];
end;
Вопрос 8
В таблице Dat хранятся данные о количестве учеников в классах (Dat[1] - количество учеников в первом классе, Dat[2] - во втором и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
Var k, m: integer;
Dat: array[1..11] of integer;
Begin
Dat[1] = 20; Dat[2] = 25;
Dat[3] = 19; Dat[4] = 25;
Dat[5] = 26; Dat[6] = 22;
Dat[7] = 24; Dat[8] = 28;
Dat[9] = 26; Dat[10] = 21;
Dat[11] = 27;
m = 0;
for k = 1 to 11 do
if Dat[k] < 25 then
begin
m = m + 1
end;
writeln(m)
End.
Вопрос 9
При наборе программы вычисления суммы отрицательных элементов массива
var a: array [1..8] of Integer;
s, k: Integer;
begin
for k = 1 to 8 do readln (a[k]);
s = 0;
for k = 1 to 8 do
If a[k] < 0 Then s = s + a[k];
writeln (s)
end.
в записи оператора s := s + a[k] была допущена ошибка - вместо него был записан оператор s := s + 1. Каким оказался ответ после исполнения неверной программы, если в качестве элементов массива были введены числа: 1, -3, -2,- 4, -5, -6, -7, 8?
Вопрос 10
Массив содержит следующие элементы a={4, 3, 8, 2, 5, 7, 3, 6, 9, 11, 1}
Чему будет равно значение переменной s после выполнения фрагмента
программы:
s:=0;
For i:=1 to 11 do
begin
If (a[i]> 3) and (a[i] <8) then s:=s+a[i];
End;
Writeln(‘s=’,s);


