Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Общие сведения о языке программирования Python (повторение)

Общие сведения о языке программирования Python (повторение)

Avatar
20.11.2025. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тест на повторение материала 8 класса, состоит из 10 вопросов. Время выполнения 15 минут

Список вопросов теста

Вопрос 1

Какие из следующих последовательностей символов можно считать операторами присваивания?
(укажите все верные ответы)

Варианты ответов
  • a+=1
  • a = b + 10
  • c = 3c
  • 2b = b + a
  • d = 25
Вопрос 2

Соотнесите служебные слова языка Python с их значениями (если вариант ответа неверный, поставьте знак ---)

1.

while

2.

for i in range (n):

3.

float

4.

print()

5.

a = int(input())

Варианты ответов
  • пока
  • цикл с параметром
  • вещественный тип
  • печать
  • ввод целого числа
  • ввод строки
Вопрос 3

Соотнесите знак операции с его значение (в неверном ответе поставьте знак  ---)

1.

остаток от деления

2.

целочисленное деление

3.

знак "не равно"

4.

знак больше или равно

5.

оператор сравнения

6.

возведение в степень

Варианты ответов
  • %
  • //
  • !=
  • >=
  • ==
  • **
  • *=
Вопрос 4

Расположите строки так, чтобы получилась программа, рассчитывающая стоимость покупки по двум введенным с клавиатуры  числам 

А - цена за 1 штуку
В - количество штук .

В ответе запишите правильную последовательность номеров.

Варианты ответов
  • print ("Введите цену и количество)
  • А = float(input())
  • B = int(input())
  • S = A * B
  • print ("Стоимость покупки =", S, "руб")
Вопрос 5

Дан фрагмент программы:
а, b = mар(int, inрut() .sрlit ())
с = 0
if а > 0:
    if b > 0:
        с = 3
else : с = 0

Определите значение переменной c при следующих значениях a = 2 и b = -3

Ответ запишите в виде числа (например, 4)

Вопрос 6

Дан условный оператор:
if а < 8:    с = 1
elif а < 20:    с = 2
else: с = 5

Какое значение в результате выполнения условного оператора примет переменная с, если переменной a будет присвоено число 25? (Запишите в ответе только число)

Вопрос 7

Определите значения переменных s  после выполнения фрагмента программы.

s = 0
i = 0
whilе i < 2:
    i += 1
    s = s + i
print(s)

Ответ запишите в строку в виде числа

Вопрос 8

Найдите значение переменной s после выполнения программы

s = 0
for х in rапge (5, 7) :
     s += 1

В ответе напишите только одно число

Вопрос 9

Условный оператор
if  а % 2 == 0:
   priпt ('Да')
еlse:
   priпt ('Нет')

позволяет определить, является ли число а:

Варианты ответов
  • нечётным
  • чётным
  • двузначным
  • простым
Вопрос 10

Определите, что будет выведено в результате работы следующей программы. (вспомните, сколько раз будет выполнено тело цикла со счетчиком)

а = 4
b = 3
fоr i in rаngе (0, 2) :
    а = а  + а // 3
    b = b + a
priпt (а + b)

Варианты ответов
  • 20
  • 30
  • 40
  • нет верного ответа
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт