Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Начала программирования на языке Python

Начала программирования на языке Python

Avatar
11.05.2023. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Обобщить и систематизировать знания по теме "Начала программирования"

Список вопросов теста

Вопрос 1

Разработчиком языка Python является:

Варианты ответов
  • Блез Паскаль
  • Гвидо ван Россум
  • Никлаус Вирт
Вопрос 2

Что из нижеперечисленного входит в алфавит языка Python?

Варианты ответов
  • знак подчёркивания
  • латинские строчные и прописные буквы
  • русские строчные и прописные буквы
Вопрос 3

Какая последовательность символов НЕ может служить именем в языке Python?

Варианты ответов
  • _mas
  • 2d
  • mas1
Вопрос 4

Вещественные числа имеют тип данных:

Варианты ответов
  • int
  • float
  • bool
Вопрос 5

При присваивании изменяется:

Варианты ответов
  • имя переменной
  • тип переменной
  • значение переменной
Вопрос 6

Для вывода результатов в Python используется оператор

Варианты ответов
  • input ()
  • print ()
  • and
Вопрос 7

Определите значение переменной с после выполнения следующего фрагмента программы.

а = 100

Ь = 30

а = а - b * 3

if а > b:

    с = а - b

else:

    с = b - а

Вопрос 8

Какого оператора цикла не существует в языке Python?

Варианты ответов
  • for
  • while
  • repeat... until
Вопрос 9

Определите значения переменных s и i после выполнения фрагмента программы.

s = 0

i = 5

while i > 0:

    s += i

    i -= 1

Варианты ответов
  • s = 0; i = -1
  • s = 5; i = 0
  • s = 15; i = 5
  • s = 15; i = 0
Вопрос 10

Какой оператор здесь используется

If n < 100:

    b = n + a

Варианты ответов
  • Условный оператор
  • Оператор сложения
  • Оператор умножения
Вопрос 11

В какой строке правильно записан ввод числа с клавиатуры?

  1. a = int(input))
  2. b=input(int())
  3. c=int(input())
  4. s=a+b+c
  5. print(s)
Вопрос 12

Сколько раз программа напишет слово «Пока»?

k=0

while k<10:

    print(«Привет»)

    k += 1

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт