Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Начала программирования на языке Паскаль

Начала программирования на языке Паскаль

Avatar
25.05.2020. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Итоговый тест по главе "Начала программирования". За 25 минут необходимо ответить на 25 вопросов.

Список вопросов теста

Вопрос 1

Разработчиком языка Паскаль является:

Варианты ответов
  • Блез Паскаль
  • Никлаус Вирт
  • Норберт Винер
  • Эдсгер В. Дейкстра
Вопрос 2

Что из нижеперечисленного не входит в алфавит языка Паскаль?

Варианты ответов
  • латинские строчные и прописные буквы
  • служебные слова
  • русские строчные и прописные буквы
  • знак подчёркивания
Вопрос 3

Какая последовательность символов не может служить именем в языке Паскаль?

Варианты ответов
  • __mas
  • maS1
  • d2
  • 2d
Вопрос 4

Вещественные числа имеют тип данных:

Варианты ответов
  • real
  • integer
  • boolean
  • string
Вопрос 5

В программе на языке Паскаль обязательно должен быть:

Варианты ответов
  • заголовок программы
  • блок описания используемых данных
  • программный блок
  • оператор присваивания
Вопрос 6

Какого раздела не существует в программе, написанной на языке Паскаль?

Варианты ответов
  • заголовка
  • примечаний
  • описаний
  • операторов
Вопрос 7

Языковые конструкции, с помощью которых в программах записываются действия, выполняемые в процессе решения задачи, называются:

Варианты ответов
  • операндами
  • операторами
  • выражениями
  • данными
Вопрос 8

Разделителями между операторами служит:

Варианты ответов
  • точка
  • точка с запятой
  • пробел
  • запятая
Вопрос 9

Описать переменную - это значит указать её:

Варианты ответов
  • имя и значение
  • имя и тип
  • тип и значение
  • имя, тип и значение
Вопрос 10

В данном фрагменте программы:
program error;
begin
SuMmA:=25-14;
end.

ошибкой является:

Варианты ответов
  • некорректное имя программы
  • не определённое имя переменной
  • некорректное имя переменной
  • запись арифметического выражения
Вопрос 11

Какая клавиша нажимается после набора последнего данного в операторе read?

Варианты ответов
  • Enter
  • точка с запятой
  • пробел
  • Ctrl
Вопрос 12

При присваивании изменяется:

Варианты ответов
  • имя переменной
  • тип переменной
  • значение переменной
  • значение константы
Вопрос 13

Для вывода результатов в Паскале используется оператор

Варианты ответов
  • begin
  • readln
  • write
  • print
Вопрос 14

Для вычисления квадратного корня из х используется функция:

Варианты ответов
  • abs (x)
  • sqr(x)
  • sqrt (x)
  • int (x)
Вопрос 15

Для генерации случайного целого числа из интервала [10, 20) необходимо использовать выражение:

Варианты ответов
  • random*20
  • random(20)
  • random(10)+10
  • random(10) *2
Вопрос 16

В каком из условных операторов допущена ошибка?

Варианты ответов
  • if b=0 then writeln ('Деление невозможно.’);
  • if a
  • if a>b then max:=a else max:=b;
  • if (a>b) and (b>0) then c:=a+b;
Вопрос 17

В условном операторе и после then, и после else нельзя использовать:

Варианты ответов
  • оператор вывода
  • составной оператор
  • несколько операторов
  • условный оператор
Вопрос 18

Определите значение переменной с после выполнения следующего фрагмента
программы:
а:=100;
b:=30;
а:=а-b*3;
if a>b then c:=b-a else c:=a-b;

Варианты ответов
  • 20
  • 70
  • -20
  • 180
Вопрос 19

Условный оператор
if a mod 2=0 then write ('Да') else write ('Нет')
позволяет определить, является ли число а:

Варианты ответов
  • целым
  • двузначным
  • чётным
  • простым
Вопрос 20

Какого оператора цикла не существует в языке Паскаль?

Варианты ответов
  • for
  • while
  • repeat...until
  • loop
Вопрос 21

Цикл в фрагменте программы
р:=20;
repeat
р:=р*0.1
until p<0.1;

будет исполнен:

Варианты ответов
  • 0 раз
  • 1 раз
  • 2 раза
  • 3 раза
Вопрос 22

Цикл в фрагменте программы
а:=1;
b:=1;
while a+b<10 do
begin
a:=a+1;
b:=b+2
end;

выполнится:

Варианты ответов
  • 0 раз
  • 2 раза
  • 3 раза
  • бесконечно
Вопрос 23

Определите значения переменных s и i после выполнения фрагмента программы:
s:=0; i:=3;
while i>0 do
begin
s:=s+i;
i:=i-1;

end;

Варианты ответов
  • s = 0, i = -1
  • s = 6, i = 0
  • s = 15, i = 5
  • s = 15, i = 0
Вопрос 24

Выберите фрагмент программы, в котором ищется произведение 1*2*3*4*5

Варианты ответов
  • p:=0; i:=1; while i<=5 do i:=i+1; p:=p*i;
  • p:=1; i:=1; while i<6 do i:=i+1; p:=p*i;
  • р:=1; i:=1; while i<6 do begin p:=p*i; i:=i+1 end;
  • p:=1; i:=1; while i>5 do begin p:=p*i; i:=i+1 end;
Вопрос 25

В данном фрагменте программы 
s:=0;
for i:=1 to 10 do
s:=s+2*i;

вычисляется:

 

Варианты ответов
  • сумма целых чисел от 1 до 10
  • сумма чётных чисел от 1 до 10
  • удвоенная сумма целых чисел от 1 до 10
  • сумма первых десяти натуральных чётных чисел
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт