Начала программирования на языке Паскаль (часть 2)
Тест предназначен для проверки и закрепления навыков работы с операторами Паскаля.
Список вопросов теста
Вопрос 1
Определите, что будет выведено на экран после выполнения оператора: writeln ('2x2=',2*2);
Варианты ответов
- 4=4
- 2x2=4
- 4
- 2*2=4
Вопрос 2
Укажите ошибку в записи оператора:
writeln('периметр='P,'сантиметров');
Варианты ответов
- нет ошибок
- нет закрывающих кавычек
- пропущены разделительные знаки
- отсутствуют пробелы
Вопрос 3
Какой вариант из перечисленных описывает целую переменную?
Варианты ответов
- const a:integer;
- var b: integer;
- var c: real;
- const x=5;
Вопрос 4
Какое значение примет переменная B при значении A:=-10, после выполнения фрагмента программы:
if A>-5
then B:=A*3
else B:=-5-A;
Варианты ответов
- -5
- -15
- 5
- 15
Вопрос 5
Определите результаты работы фрагмента программы:
A:=-5;
B:=-3;
A:=A+2*B;
B:=-A-1;
Writeln(A,B);
Варианты ответов
- -1110
- 10,-11
- -11,10
- 10 -11
Вопрос 6
Что будет выведено на экран в результате выполнения фрагмента программы, если значение R равно -10?:
if R=0 then Y:=R*10;
if R>0 then Y:=R+10;
if R<0 then Y:=R*R/2;
writeln('Y=',Y);
Варианты ответов
- 0
- Y=-50
- 50
- Y=50
Вопрос 7
Определите значение целочисленных переменных a и b после выполнения фрагмента программы:
a:=5+8*4;
b:=(a div 10)+15;
a:=(b mod 10)+2;
Варианты ответов
- a=37, b=18
- a=10, b=18
- a=18, b=10
- a=10, b=7
Вопрос 8
Определите результат работы оператора:
writeln('Сумма=5+5');
Варианты ответов
- 10
- Сумма=5+5
- Сумма=10
- 5+5=10
Вопрос 9
Определите значение целочисленных переменных x и y после выполнения фрагмента программы:
x:=243;
y:=8;
x:=x div y;
y:=x mod y;
Варианты ответов
- x=30, y=6
- x=6, y=30
- x=31, y=3
- x=30, y=3
Вопрос 10
Укажите, сколько раз выполнится тело цикла с заданным заголовком:
FOR I:=-2 TO 2 DO
Варианты ответов
- 4
- 5
- 0
- бесконечное число раз
Вопрос 11
Какой из перечисленных заголовков циклов не содержит ошибок?
Варианты ответов
- For k=1 to 5.5 do
- for k:=1 to 5.5 do
- for 1k:=1 to 5 do
- for k:=1 to 5 do
- for k=1 to 5 do
Вопрос 12
Определите, что будет напечатано в результате работы следующей программы:
var s, k: integer;
begin
s:=10;
for k:=2 to 9 do
s:=s+2*k;
write(s);
end.
Варианты ответов
- 88
- 98
- 78
- 68


