Массивы. Описание массива
Список вопросов теста
Вопрос 1
Чему равно значение переменной s после выполнения фрагмента программы:
s:=0;
for i:=1 to 20 do
if A[i] mod 3 = 0 then s:=s+A[i];
Вопрос 2
В программе описан одномерный целочисленный массив с индексами от 0 до 10. В приведенном ниже фрагменте программы массив сначала заполняется, а потом изменяется:
for i := 0 to 10 do A[i] := i;
for i := 0 to 10 do
begin
A[10-i] := A[i];
A[i] := A[10-i];
end;
Чему будут равны элементы этого массива?
Варианты ответов
- 10, 9, 8, 7, 6, 5, 6, 7, 8, 9, 10
- 0, 1, 2, 3, 4, 5, 4, 3, 2, 1, 0
- 10,9, 8, 7, 6, 5, 4, 3, 2, 1, 0;
- 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10
Вопрос 3
Пусть элементы одномерного массива А[1..10] приобретают значения соответственно - 5, -3, -1, 1, 3, 5, 7, 9, 11, 13. Выберите, какие значения будут напечатаны в результате выполнения таких операторов:
For i:=1 to 5 write ( a[i+5], ‘ ‘);
Варианты ответов
- -5 -3 -1 1 3;
- 0 2 4 6 8;
- 5 7 9 11 13;
- 10 12 14 16 18.
Вопрос 4
Дана программа, составленная для решения задачи. Даны действительные числа а1, …, а30, в1, …, в30. Вычислить (а1+в30)*(а2+в29)*…*(а30+в1). Выберите пропущенную строку:
Type mas=array [1..30] of real;
Var a, b: mas;
i: byte; y: real;
Begin
For i:=1 to 30 do read (a[i]);
For i:=1 to 30 do read (b[i]);
y:=1;
______________________
Writeln (‘y=’, y:8:4);
End.
Варианты ответов
- For i:=1 to 30 do for j:=1to 30 do y:=y*(a[i]+b[j]);;
- y:=(a[1]+b[30])*(a[2]+b[29])*..*(a[30]+b[1]);;
- for i:=1 to 30 do y:=y*(a[i]+b[31-i]);;
- for i:=1 to 30 do y:=y*(a[i]+b[30-i]);.
Вопрос 5
Выберите из приведенного списка ошибочные записи одномерных массивов:
Варианты ответов
- Type mas=array [1..n] of byte; var a:mas;
- Var a: aray [-7..-7] of integer;
- Var a: array [10] of integer;
- Const n=10; Var a: array [1..n] of integer.
Вопрос 6
-
Массив - это ...
Варианты ответов
- максимальное возможное количество элементов
- элементы, которые размещаются друг за другом
- конечное число одинаковых величин
- обозначаемая одним именем последовательность однотипных элементов
Вопрос 7
-
В классе 30 учеников. Известен рост каждого в сантиметрах. Для хранения значений роста можно использовать массив ROST, состоящий из 30 целых чисел. Как будет выглядеть описание этого массива?
Варианты ответов
- Var ROST: array [1...30] of integer;
- Var: ROST: array [1..30] of integer;
- Var ROST: array [1..30] of real;
- Const n1=1; n2=30; Var ROST: array [n2..n1] of integer;
- Var ROST: array [1..30] of integer;
Вопрос 8
Что производит следующий фрагмент программы?
for i:=1 to n do
write(a[i],' ');
Варианты ответов
- Ввод элементов массива с клавиатуры.
- Вывод элементов массива на экран монитора.
- Ввод элементов массива из файла.
Вопрос 9
Укажите правильное обращение к элементу одномерного массива:
Варианты ответов
- A(1)
- A{1}
- [1]
- A[1]
Вопрос 10
Какой ряд данных можно назвать массивом?
Варианты ответов
- а, 4, б, 5, с, 6
- 2.3, 5.7, 10.89
- 3, 6, 3, 2, massiv


