Массивы
Список вопросов теста
Вопрос 1
Расположите по порядку этапы составления программы, для решения задач с массивами:
Варианты ответов
- Объявление массива
- Заполнение массива
- Обработка массива
- Вывод результатов
Вопрос 2
Дана модель массива B. Чему равен размер массива?
Вопрос 3
Дана модель массива B.

Определите значение элемента массива B[2]
Вопрос 4
Дана модель массива B. Укажите номер элемента массива, равного 78

Вопрос 5
Дан фрагмент программы заполнения массива a.
...
for k:=1 to 9 do
begin
a[k]:=3*k-1;
end;
...
Какие значения примут элементы массива? В ответе укажите числа через запятую без пробелов.
Вопрос 6
Выберите верный вариант объвления массива из девяти элементов, заполненного целыми значениями:
Варианты ответов
- var a:array[1..9] of integer;
- var a:integer of array[1..9];
- var a:array[size=9];
- var a:integer;
Вопрос 7
Укажите верное обозначение элемента массива a расположенном на k-том месте
Варианты ответов
- a[k]
- ak
- a-k
- k[a]
Вопрос 8
Дан фрагмент программы заполнения массива a:
for k:=1 to 8 do
begin
...;
end;
Какю строчку необходимо добавить вместо многоточия, чтобы элемента массива были равны последовательности четных чисел
Варианты ответов
- a[k]:=k*2;
- a[k]:=k+2;
- a[k]:=k/2;
- a[k]:=k*2+1;
Вопрос 9
Дан фрагмент программы заполнения массива a:
for k:=1 to 8 do
begin
...;
end;
Какю строчку необходимо добавить вместо многоточия, чтобы массив был заполнен случайными числами из интервала [-10,10].
Варианты ответов
- a[k]:=random(21);
- a[k]:=random(21)-10;
- a[k]:=random(21)+10;
- a[k]:=random(41)/2;
Вопрос 10
Отметьте все правильные утверждения о массивах в языке Паскаль.
Варианты ответов
- элементы массива могут быть разных типов
- все элементы массива должны быть одного типа
- элементы в памяти расположены рядом
- элементы могут быть расположены в памяти по одному
- элементы всегда нумеруются с единицы
Вопрос 11
Сколько байт в памяти занимает массив A, если на целое число отводится 4 байта?
var A: array[-3..2] of integer;
Вопрос 12
Требуется заполнить массив именно так:
X = [1, 3, 5, 7, 9, 11]
Какой оператор надо поместить в тело цикла вместо многоточия?
for k:=1 to 6 do begin
...
end;
Варианты ответов
- X[k] := k
- X[k] := 2*k
- X[k] := 2*k - 1
- X[k] := 2*k + 1
- X[k] := 2*(k - 1)
Вопрос 13
Требуется заполнить массив именно так:
X = [12 9 6 3 0 -3]
Какой оператор надо поместить в тело цикла вместо многоточия?
for k:=1 to 6 do begin
...
end;
Варианты ответов
- X[k] := k
- X[k] := 14 - 2*k
- X[k] := 3*k - 15
- X[k] := 3*(k - 1) + 6
- X[k] := 15 - 3*k
Вопрос 14
В таблице Dat хранятся данные о количестве сделанных учениками заданий (Dat[1] заданий сделал первый ученик, Dat[2] – второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
var Dat: array[1..7] of integer;
k, day: integer;
begin
Dat[1] := 9; Dat[2] := 11;
Dat[3] := 10; Dat[4] := 13;
Dat[5] := 8; Dat[6] := 5;
Dat[7] := 11;
day := 0;
for k := 1 to 7 do begin
if Dat[k] <= 10 then day := day+1;
end;
writeln(day);
end.
Вопрос 15
В таблице Dat хранятся данные измерений среднесуточной морской воды в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
var Dat: array[1..7] of integer;
k, day: integer;
begin
Dat[1] := 19; Dat[2] := 21;
Dat[3] := 20; Dat[4] := 23;
Dat[5] := 24; Dat[6] := 25;
Dat[7] := 23;
day := Dat[1];
for k := 1 to 7 do begin
if Dat[k] > day then day := Dat[k]
end;
writeln(day);
end.
Вопрос 16
Известная авиакомпания заносила данные о количестве утерянного багажа за год в таблицу Lose. Всего были занесены данные за последние 10 лет работы компании (Lose[1] – количество утерянного багажа за первый год работы, Lose[2] – за второй год и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.
Var t, m: integer;
Lose: array[1..10] of integer;
Begin
Lose[1] := 1; Lose[2] := 5;
Lose[3] := 3; Lose[4] := 6;
Lose[5] := 7; Lose[6] := 12;
Lose[7] := 1; Lose[8] := 3;
Lose[9] := 3; Lose[10] := 1;
m := 0;
For t := 1 to 10 Do
If Lose[t] > 3 Then Begin
m := m + Lose[t];
End;
Writeln(m);
End.


