Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Контрольная работа "Программирование на Python" 9 класс

Контрольная работа "Программирование на Python" 9 класс

Avatar
22.12.2021. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Работа содержит вопросы по теме "Программирование" (первый год обучения)

Список вопросов теста

Вопрос 1

Определите значение переменной a после выполнения алгоритма:

  a = 4
  b = 6
  b = 8 + a * b
  a = b / 4 * a

Вопрос 2

Определите значение переменной а после исполнения данного алгоритма.

  a = 12
  b = 8 + a / 2
  a = a – b / 2

Вопрос 3

Чему будет равна переменная «c» после выполнения этой программы:

  a = 26
  b = 6
  b = a // b + b
  c = a % b + a

Вопрос 4

Чему будет равна переменная «c» после выполнения этой программы:

  a = 22
  b = 4
  b = a // b
  c = a // b

Вопрос 5

Чему будет равна переменная «c» после выполнения этой программы:

  a = 28
  b = 7
  b = a % b + 4
  c = a % b + 1

Вопрос 6

Определите значение переменной «a» после выполнения фрагмента программы:

  a = 10
  if a < 5:
    a += 12
  else:
    a -= 7

Вопрос 7

Определите значение переменной «a» после выполнения фрагмента программы:

  a = 10;
  if a > 5: a += 12
  else:     a -= 7
  if a > 5: a += 12
  else:     a -= 7

Вопрос 8

Сколько раз будет выполнен этот цикл?

  i = 4
  while i < 2:
    print ( "
Привет!" )
    i += 1

Вопрос 9

Чему будет равно значение переменной «a» после выполнения этого цикла?

  i = 2
  a = 12
  while i < 5:
    a += i
    i += 1

Вопрос 10

Определите, что будет напечатано в результате работы следующей программы.

  s = 1
  for k in range(1, 8):
    s = s + k
  print( s )

Вопрос 11

Определите, что будет напечатано в результате работы следующей программы.

  s = 0
  for k in range(14, 19):
    s = s + 7
  print( s )

Вопрос 12

Что будет выведено на экран после выполнения программы?

  s = "123"
  s = s + "0" + s;
  s = s + s;
  print ( s )

Вопрос 13

Что будет выведено на экран после выполнения этой программы?

  s = "12345"
  n = len(s) + len("456")
  print ( n )

Вопрос 14

Что выведет на экран эта программа:

  s = "инф"
  q = "a" * 5
  s = s + q
  print(s)

Вопрос 15

Что выведет на экран эта программа?

  s = "информатика"
  print ( s[5] )

Вопрос 16

Для массива  5 2 8 3 1 7

определите, какое значение будет выведено:

sum = 0

for i in range(N):

  if A[i] % 2 == 0:

    sum += A[i] 

print( sum )

 

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт