Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Язык программирования Python

Язык программирования Python

Avatar
17.03.2025. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Вариант 4 проверка знаний по темам: "Оператор присваивания", "Сложные условия", "Программы с циклами ", "Обработка массивов"

Список вопросов теста

Вопрос 1

Определите значение переменной а после выполнения данного алгоритма:

  a = 4
  b = 4
  b = a + 2 * b
  a = a * 5 // b

В ответе укажите одно целое число – значение переменной а.

Вопрос 2

Определите значение переменной а после выполнения данного алгоритма:

  b = 8
  a = 9
  b = b + a * 2
  a = 29 - a 

В ответе укажите одно целое число – значение переменной b.

Вопрос 3

Ниже приведена программа, записанная на языке программирования Python.

x = int(input())
y = int(input())
if x >= 5 and y > 5:
    print(’True’)
else:
    print(’False’)

Было проведено 9 запусков программы, при которых в качестве значений переменных x и y вводились следующие пары чисел:

(6, 8); (3, 5); (–7, 2); (7, 7); (9, 8); (–1, 3); (–4, 5); (6, 9); (2, –1).

Сколько было запусков, при которых программа напечатала ’False’?

Вопрос 4

Дана программа:

x = int(input())
y = int(input())
if y <= 100 or x > 90:
   print("ДА")
else:
   print("НЕТ")

Было проведено 10 запусков этой программы, при которых в качестве значений переменных x и y вводились следующие пары чисел:

  (105, 100); (95, 110); (100, 95); (95, 90); (105, 90); 
(85, 110); (100, 110); (85, 105); (85, 95); (90, 100)

Сколько было запусков, при которых программа напечатала «НЕТ»?

Вопрос 5

Дана программа:

s = int(input())
t = int(input())
A = int(input())
if s < A and t < 5:
     print("ДА")
else:
     print("НЕТ")

Было проведено 9 запусков этой программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

  (10, 15); (-6, -3); (11, 5); (8, -8); (4, -11); 
(12, 5), (-11, -8), (15, 0), (10, 7) 

Сколько существует целых значений параметра А, при котором для указанных входных данных программа напечатает «НЕТ» 5 раз.

Вопрос 6

Определите, что будет напечатано в результате работы следующей программы.

  k = 4
  for i in range(1, 4):
    k = k + i
  print( k )
Вопрос 7

В таблице Work хранятся данные о количестве заказов, принятых фирмой «Алоэ» с первого по 15 ноября. (Work[0] - число заказов, принятых 1 ноября, Work[1] - 2 ноября и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.

  Work = [5, 4, 5, 7, 6, 12, 7, 3, 9, 7, 0, 9, 1, 0, 8]			
  m = 0					
  for k in range(15):
    if Work[k] < 7:
      m = m + 1	
  print( m )
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт