Язык программирования Паскаль
Повторение по теме "Язык программирования Паскаль": основные алгоритмические конструкции, переменные, оператор присваивания, ветвление, циклы.
Список вопросов теста
Вопрос 1
Линейным называется алгоритм, в котором:
Варианты ответов
- выполнение операций зависит от условия
- операции выполняются друг за другом
- одни и те же операции выполняются многократно
- присутствуют все возможные операции
Вопрос 2
Циклическим называется алгоритм, в котором:
Варианты ответов
- выполнение операций зависит от условия
- операции выполняются друг за другом
- одни и те же операции выполняются многократно
- присутствуют все возможные операции
Вопрос 3
Если ход выполнения алгоритма зависит от истинности тех или иных условий, то он называется:
Варианты ответов
- линейным
- циклическим
- разветвляющимся
- вложенным
Вопрос 4
Определите значение целочисленной переменной Х после выполнения фрагмента программы:
X:=1;
while X<10 do begin
X:=X+3;
X:=X+1
end;
Варианты ответов
- 8
- 12
- 11
- 13
Вопрос 5
Чему будет равен результат выполнения фрагмента программы?
a:=12;
if a div 2 >=6
then b:=a mod 5
else b:=a div 3;
write(a-b);
Вопрос 6
Какое значение примет переменная С после выполнения действия С:=6+36/6?
Варианты ответов
- 7
- 6
- 12
- 1
Вопрос 7
Установите соответствие между типами величин и их значениями.
1. целое число
2. вещественное число
3. символьная величина
4. логическая величина
Варианты ответов
- TRUE
- 100
- '14,53'
- 14.53
Вопрос 8
Установите соответствие между типами величин и их значениями.
1. целое число
2. вещественное число
3. символьная величина
4. логическая величина
Варианты ответов
- A<=B
- количество столовых приборов в сервизе
- название улицы
- средний рост учеников класса
Вопрос 9
Пусть a=3, b=5, c=7. Какие значения будут иметь эти переменные в результате выполнения последовательности операторов:
c:=a*b+2; b:=b+1; a:=sqr(b)-c; b:=b*a?
Запишите последовательно значения переменных a, b, c через запятую.
Вопрос 10
Тело цикла - это
Варианты ответов
- группа команд, не входящих в циклическую структуру
- произвольная группа команд
- группа команд, повторяющихся некоторое число раз
- группа команд программы, содержащей циклическую структуру


