Язык программирования Паскаль. Цикл While.
Список вопросов теста
Вопрос 1
Языковые конструкции, с помощью которых в программах записываются действия, выполняемые в процессе решения задачи, называются
Варианты ответов
- операндами
- операторами
- выражениями
- данными
Вопрос 2
Дан фрагмент линейного алгоритма:
a := 8;
b := 6 + 3 * a;
a := b / 3 * a;
Чему равно значение переменной a после его исполнения? В ответе укажите только число.
Вопрос 3
Определите значение целочисленных переменных х и у после выполнения фрагмента программы:
х := 11;
у := 5;
t := у;
у := х mod у;
х := t;
у := у + 2*t
Варианты ответов
- х = 5, у = 10
- х = 10, у = 5
- х = 5, у = 11
- х = 11, у = 5
Вопрос 4
Для вычисления квадратного корня из Х используется функция
Варианты ответов
- abs (х)
- sqr (х)
- sqrt(х)
- int (х)
Вопрос 5
Описать переменную - это значит указать её
Варианты ответов
- имя и значение
- имя и тип
- тип и значение
- имя, тип и значение
Вопрос 6
Разделителями между операторами в языке Паскаль служит
Варианты ответов
- точка
- точка с запятой
- запятая
- пробел
Вопрос 7
Определите значение переменной С после выполнения следующего фрагмента программы:
a := 100;
b := 30;
a := a - b *3;
if a = b then с := a - b else с := b - a.
В ответе укажите число.
Вопрос 8
Какой вариант описывает вещественную переменную на языку Pascal?
Варианты ответов
- var x: integer;
- var x: boolean;
- var x: real;
- var x: string.
Вопрос 9
Укажите, правильную запись следующего математического выражения: \(y=5x^2-10x+2\)
Варианты ответов
- y:= 5*sqr(x)-10*x+2;
- = 5_sqrt(x)-10_x+2
- = 5_sqr(x)-10x+2
- = 5sqr(x)-10_x+2_
Вопрос 10
Какие значения примут переменные С и D в результате выполнения программы:
Program V1;
Var A, B, C, D : integer;
Begin
A:=6;
B:=2*A+8;
If B>A then C:= B-A else D:=A-B;
Writeln (‘C=’, C);
Writeln (‘D=’, D);
End.
В ответе значения чисел запишите через запятую.
Вопрос 11
Что выведет на экран оператор Writeln('15+15=',15+15); ?
Варианты ответов
- 15+15=15+15.
- 30=30;
- 15+15=30;
- 60;
Вопрос 12
Как ввести с клавиатуры значение в переменную k?
Варианты ответов
- с помощью оператора присваивания;
- с помощью оператора ввода;
- с помощью оператора вывода;
- нажать клавишу «ENTER».
Вопрос 13
Укажите выражение, записанное с помощью стандартных математических функций, соответствующее математической записи
Варианты ответов
- (1/x+sqr(x))/2x;
- 1/x+sqr(x)/2*x;
- 1/x+sqrt(x))/2*x.
- (1/x+sqr(x))/2*x;
Вопрос 14
Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:
(1, 2); (11, 2); (1, 12); (11, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5).
var s, t: integer; begin readln(s); readln(t); if (s > 10) or (t > 10) then writeln('YES') else writeln('NO') end.
В ответе укажите число , которое указывает сколько раз выведет программа YES.
Вопрос 15
Запишите значение переменной s (в ответе укажите только число), полученное в результате работы следующей программы:
var k, s: integer; begin s:=0; k:=0; while s < 80 do begin s:=s+2*k; k:=k+4; end; write(s); end.
Вопрос 16
Запишите значение переменной С (в ответе укажите только число), полученное в результате работы следующей программы:
a := 17; b := 20; a := 3 * a - b; if a > b then c := 5 * a - b else c := 5 * a + b;
Вопрос 17
Запишите значение переменной s (в ответе укажите только число), полученное в результате работы следующей программы:
var k, s: integer; begin s:=0; k:=0; while k < 12 do begin s:=s+2*k; k:=k+3; end; write(s); end.