Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  Язык Питон. Ветвления. Циклические алгоритмы

Язык Питон. Ветвления. Циклические алгоритмы

Avatar
08.02.2022. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
В тесте рассматриваются основные понятия языка программирования Питон, Ветвления. Циклические алгоритмы. Функции.

Список вопросов теста

Вопрос 1

________ оператор предназначен для выбора из двух вариантов действий.

Вопрос 2

______________ программы, в которых операторы выполняются последовательно друг за другом, и их порядок не зависит от входных данных.

Вопрос 3

Какой фрагмент программы позволяет записывать в переменную M максимальное из двух значений переменных c и d?

Варианты ответов
  • IF c>d: M=c else: M=d
  • M=max(c,d)
  • IF c>d: M=d
Вопрос 4

Установите соответствие следующих высказываний:

1.

меньше или равно

2.

больше или равно

3.

равно

4.

не равно

Варианты ответов
  • <=
  • >=
  • ==
  • !=
Вопрос 5

При выполнении сложного логического выражения действия выполняются в следующем порядке:

Варианты ответов
  • операции отношения
  • операции not
  • операции and
  • операции or
Вопрос 6

________ - это многократное выполнение одинаковых действий.

Вопрос 7

Указать результат работы следующей программы:

n=int(input())

k=0

while n>0:

  n=n//10

  k+=1

print(k)

Варианты ответов
  • количество цифр заданного числа
  • целые остатки от деления
Вопрос 8

Указать n при котором в результате работы программы 5 раз будет выведено "Добрый день":

n=int(input())

k=0

while k<=n:

  print ("Добрый день")

  k+=1

Варианты ответов
  • 5
  • количество "Добрый день"
  • 4
  • нет ответа
Вопрос 9

Какая из программ позволяет вычислять степень числа 3?

Варианты ответов
  • t=1 while t<=5: print (3**t) t+=1
  • for m in ranqe (1,6): print (3**m)
  • for m in ranqe (1,6,-1): print (3**m)
Вопрос 10

Указать правильные высказывания:

Варианты ответов
  • Вложенный цикл - это цикл, находящийся в теле другого цикла.
  • Для организации циклов с заданным числом повторений нужно использовать переменную-счетчик.
  • В языке Питон используется 3 вида циклов.
Вопрос 11

Ниже записана программа. Получив на вход число x, эта программа печатает два числа. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 10.

x = int(input())

k = 0; p = 1

while x > 0:

    k = k + 1

    p = p * (x % 10)

    x = x // 10

print(k, p)  

Вопрос 12

Ниже записана программа. Получив на вход число x, эта программа печатает два числа. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 6.

  x = int(input())
  k = 0; n = 0
  while x > 0:
    k = k + 1
    if x % 2 == 1:
      n = n + x % 10
    x = x // 10
  print(k, n)

Вопрос 13

Ниже записана программа. Получив на вход число x, эта программа печатает два числа. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 6.

  x = int(input())
  k = 0; p = 0
  while x > 4:
    k = k + 1
    if p < x % 10:
      p = x % 10;
    x = x // 10
  print(k, p)

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт