Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  Базовые элементы языка Паскаль

Базовые элементы языка Паскаль

Avatar
02.02.2019. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Повторение базовых элементов языка Паскаль и структуры программы.

Список вопросов теста

Вопрос 1

Линейная структура построения программы подразумевает:

Варианты ответов
  • Неоднократное повторение отдельных частей программы.
  • Последовательное выполнение всех элементов программы.
  • Выполнение лишь нескольких, удовлетворяющих заданному условию частей программы.
  • Верного ответа нет.
Вопрос 2

Оператор присваивания имеет вид:

Варианты ответов
  • =
  • :=
  • =:
  • <>
Вопрос 3

Раздел VAR необходим для...

Варианты ответов
  • описания используемых переменных
  • описания символов
  • описания выражений
  • верного ответа нет
Вопрос 4

Переменные - это ...

Варианты ответов
  • величины, которые могут изменять своё значение в процессе выполнения программы
  • величины, которые не могут менять своего значения в процессе выполнения программы
  • обозначают строки программы, на которые передается управление во время выполнение программы
  • верного ответа нет
Вопрос 5

Целочисленное деление можно выразить следующей функцией - ...

Варианты ответов
  • A mod B
  • A div B
  • Abs (A)*B
  • A and B
Вопрос 6

Раздел операторов начинается служебным словом...

Варианты ответов
  • VAR
  • INTEGER
  • BEGIN
  • PROGRAM
Вопрос 7

Ввод данных с клавиатуры осуществляется с помощью оператора:

Варианты ответов
  • WRITE, WRITELN
  • READ, READLN
  • VAR
  • нет правильного ответа
Вопрос 8

Вывод данных на экран осуществляется с помощью оператора:

Варианты ответов
  • WRITE, WRITELN
  • READ, READLN
  • BEGIN
  • Верного ответа нет
Вопрос 9

Чему будет равно значение переменной М в результате выполнения серии операторов:

N:=5;

Y:=2;

M:=N/5+3*Y*N;

Вопрос 10

Тип переменных REAL  - это...

Варианты ответов
  • целочисленный тип
  • логический тип
  • натуральный тип
  • верного ответа нет
Вопрос 11

Отметьте верные имена идентификаторов:

Варианты ответов
  • F
  • f
  • Ф
  • Su
  • S u
  • n1
  • S-1
  • _S1
  • 5D
  • End
  • Ent
Вопрос 12

Определите правильный результат выполнения фрагмента программы:

a:=20; b:=a div 4;
c:=b+a+0.251;
a:=a+6;
a:=a div 2;
writeln('a=',a,'b=',b);
writeln('c=',c:8:2);

Варианты ответов
  • a=6; b=5; c=11.256
  • a=26; b=5; c=31.25
  • a=13; b=5; c=18.25
  • a=13; b=5; c=25.25
Вопрос 13

Определите значение выражения  3 div 10 + 25 mod 5

Варианты ответов
  • 3
  • 8
  • 0
  • 6
Вопрос 14

В какой последовательности должны выполнятся строки программы, чтобы программа соответствовала решению задачи?
Задача. Вычислите значение радиуса R=(ABC)/4S вписанной в треугольник окружности, если заданы стороны треугольника А, В, С.
{1} begin
{2} readln (A,B,C);
{3} S:=SQRT(P*(P-A)*(P-B)*(P-C));
{4} P:=(A+B+C)/2;
{5} writeln('R=',R);
{6} end.
{7} R:=(A*B*C)/(4*S);

Варианты ответов
  • 4, 1, 2, 7, 6, 5 3
  • 1, 2, 4, 3, 7, 5, 6
  • 1, 2, 3, 4, 7, 5, 6
Вопрос 15

Чему равно значение выражения:

trunc(sqrt(2+52 div 8))-sqr(15 mod 4/3)

Вопрос 16

Какое расширение должен иметь файл, созданный на языке Pascal?

Варианты ответов
  • *.py
  • *.pac
  • *.pas
  • *.sap
  • *.exe
Вопрос 17

Выделите основные этапы разработки программ?

Варианты ответов
  • просмотр
  • внедрение
  • отладка
  • переписывание
  • продажа
  • тестирование
  • программирование
Вопрос 18

Что такое "компиляция"?

Варианты ответов
  • процесс перевода исходного текста программы в исполняемый код
  • процесс перевода исполняемого кода программы в исходный текст
  • процесс исправления ошибок в программе
  • процесс исполнения программы на компьютере
Вопрос 19

Что такое "отладка" программы?

Варианты ответов
  • процесс перевода исходного текста программы в исполняемый код
  • процесс перевода исполняемого кода программы в исходный текст
  • процесс исправления ошибок в программе
  • процесс исполнения программы на компьютере
Вопрос 20

Чему будет равна переменная "r" после выполнения фрагмента программы:
a:=333;
s:=a div 100;
d:=(a-s*100) div 10;
e:=a-s*100-d*10;
b:=e*100+d*10+s;
r:=a-b;

 

Вопрос 21

Выберите данные, которые могут быть  числами вещественного типа:

Варианты ответов
  • 1.1
  • 0
  • -33%
  • .765
  • -33
  • 1Е3
  • +98
  • 1.33Е-5
Пройти тест
Сохранить у себя:

Комментарии 1

Чтобы добавить комментарий зарегистрируйтесь или на сайт

Пользователь, 11.02.2019 22:52

А где ответы можно посмотреть?