Меню
Тесты
Тесты  /  Информатика  /  10 класс  /  Алгоритмы обработки массива

Алгоритмы обработки массива

Avatar
27.04.2020. Тест. Информатика, 10 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
В тесте представлены задания по теме вычисление суммы элементов массива, поиск наименьшего или наибольшего элемента массива, отбор элементов согласно условию

Список вопросов теста

Вопрос 1

В программе для заполнения массива используется выражение a[t]:=random(33)+20. В каком интервале будут находиться значения элементов массива?

 

Варианты ответов
  • [20,33]
  • [20,52]
  • [0,33]
  • [0,52]
Вопрос 2

По условию задачи в таблице храняться значения, принадлежащие диапазону [-15,30]. Какое выражения следует использовать в программе для заполнения массива этими  значениями?

Варианты ответов
  • a[k]:=random(30)
  • a[k]:=random(45)
  • a[k]:=random(30)-15
  • a[k]:=random(46)-15
Вопрос 3

В таблице А хранятся данные о количестве призеров олимпиады по программированию по 9-ти округам Москвы. Определите, что будет напечатано в результате выполнения следующего алгоритма.

var k, score: integer;
    A: array[1..9] of integer;
begin
  A[1] :=6; A[2] := 11;
  A[3] := 7; A[4] := 12;
  A[5] := 13; A[6] := 5;
  A[7] := 9; A[8] := 3;
  A[9] :=4;
  score := 0;
  for k:=1 to 9 do begin
    if A[k] >= 9 then
      score:= score+A[k];
  end;
  write(score);
end.

Вопрос 4

В таблице Dat хранятся данные измерений среднесуточной температуры в градусах (Dat[1] – данные за первый день, Dat[2] – за второй и т. д.). Определите, какое число будет напечатано в результате работы следующей программы.

var Dat: array[1..7] of integer;
    k, day: integer;
begin
  Dat[1] := 9; Dat[2] := 11;
  Dat[3] := 10; Dat[4] := 13;
  Dat[5] := 8; Dat[6] := 5;
  Dat[7] := 11;
  day := 0;
  for k := 1 to 7 do begin
    if Dat[k] <= 10 then
      day := day+1;
  end;
  writeln(day);
end.

Вопрос 5

Дана модель массива a.
Чему будет равно значение переменной S после выполнения фрагмента программы?
s:=0;
for k:=1 to 10 do
        begin
          if a[k]>0 then s:=s+a[k];
        end;
writeln(s);
end.

Вопрос 6

Дана модель массива a.

Чему будет равно значение переменной c  после выполнения фрагмента программы:

с:=0;
for k:=1 to 10 do
        begin
          if a[k] mod 2 = 0 then c:=c+1;
        end;
writeln(c);
end.

Вопрос 7

Дана модель массива a.

После выполения фрагмента программы
c:=0;
for k:=1 to 10 do
        begin
          if ... then c:=c+1;
        end;
writeln(c);
end.
на экране появилось число 2.
Какой при этом оператор сравнения должен быть вместо многоточия?

Варианты ответов
  • a[k]=2
  • a[k] mod 2<>0
  • a[k]>2
  • a[k]<2
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт