Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  8.3.4 Python. Цикл for

8.3.4 Python. Цикл for

Avatar
26.09.2022. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тест содержит 15 вопросов. Ограничение по времени 15 минут

Список вопросов теста

Вопрос 1

Назначение циклической структуры:

Варианты ответов
  • повторение идущих подряд одинаковых команд некоторое число раз
  • повторение одной команды не более 10 раз
  • проверка условия в тексте
  • повторение группы команд некоторое число раз
Вопрос 2

Тело цикла - это...

Варианты ответов
  • группа команд, не входящих в циклическую структуру
  • произвольный текст
  • группа команд, повторяющихся некоторое число раз
Вопрос 3

В записи
for a in range(10):
    x=x+7
запись
for a in range(10):

означает
 

Варианты ответов
  • тело цикла
  • заголовок цикла
  • выполняемый цикл
Вопрос 4

В записи
for a in range(10):
    x=x+7
запись
x=x+7
означает

Варианты ответов
  • тело цикла
  • заголовок цикла
  • выполняемый цикл
Вопрос 5

Что является назначением представленного фрагмента программы:
s=0
for x in range(1,101):
   s+=x
print(s)

Варианты ответов
  • Вычисление сотой степени числа х
  • Вычисление суммы ста чисел, введенных пользователем
  • Вычисление суммы первых ста натуральных чисел
Вопрос 6

Что является назначением представленного фрагмента программы:
s=1
for a in range(1,10):
    s*=a
print(s)

Варианты ответов
  • Вычисление сотой степени числа х
  • Вычисление произведения первых десяти натуральных чисел
  • Вычисление суммы первых десяти натуральных чисел
Вопрос 7

Что является назначением представленного фрагмента программы:
s=1
for a in range(10):
    s*=2
print(s)

Варианты ответов
  • Вычисление десятой степени числа 2
  • Вычисление произведения первых десяти натуральных чисел
  • Вычисление произведения десяти чисел, введенных пользователем
Вопрос 8

Укажите, сколько звездочек будет напечатано на экране:
for i in range(10):
    print('*')

Вопрос 9

Укажите, сколько звездочек будет напечатано на экране:
for i in range(3,11):
    print('*')

Вопрос 10

Укажите, сколько звездочек будет напечатано на экране:
for i in range(3,13,4):
    print('*')

Вопрос 11

Определите значение переменной s после выполнения программы:
s=0
for i in range(5):
    s+=i

Вопрос 12

Определите значение переменной s после выполнения программы:
s=0
for i in range(3):
    s+=i*3

Вопрос 13

Определите значение переменной s после выполнения программы:
s=0
for i in range(5):
    s+=i*2

Вопрос 14

Определите значение переменной s после выполнения программы:
s=1
for i in range(5):
    s*=i

Вопрос 15

Определите значение переменной s после выполнения программы:
s=1
for i in range(1,5):
    s*=i

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт