Меню
Тесты
Тесты  /  Информатика  /  11 класс  /  10 класс. Python

10 класс. Python

Avatar
15.11.2025. Тест. Информатика, 11 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Промежуточный тест по программированию на языке Python для базового уровня На тест 15 минут. 16 вопросов.

Список вопросов теста

Вопрос 1

Какие величины могут изменять свое значение при выполнении программы?

Варианты ответов
  • константы
  • переменные
  • служебные слова
Вопрос 2

Как в языке Python обозначается целочисленный тип данных?

Варианты ответов
  • int
  • float
  • input
  • bool
Вопрос 3

Определи, какая арифметическая операция выполняется в выражении: 9 // 2

Варианты ответов
  • нахождение остатка от деления
  • целочисленное деление
  • деление
  • возведение в степень
Вопрос 4

Определи, что будет результатом выполнения арифметического выражения: 19%3*2

Варианты ответов
  • 0
  • 1
  • 12
  • 3
  • 2
Вопрос 5

Что получится  в результате выполнения программы:

a = 12

b = a + 2

a = b * 93

print(a)

Варианты ответов
  • 1302
  • 2400
  • 420
  • 1240
Вопрос 6

Что будет в результате выполнения следующего алгоритма при вводе числа 34:

print("введите число ")

x = int(input())

if x > 0:

      print(x**2)

else:

      print(-x/2)

Варианты ответов
  • 1156
  • 17
  • -17
  • 34
  • 68
Вопрос 7

s = int(input())
t = int(input())
if s < 7 or t > 5:
    print("YES")
else:
    print("NO")

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(9, 5); (11, 2); (4, 5); (7, –2); (4, 4); (7, 7); (1, –1); (3, 9); (2, 2).

Сколько было запусков, при которых программа напечатала «YES»?

Варианты ответов
  • 6
  • 3
  • 0
  • 9
  • 5
  • 4
Вопрос 8

s = int(input())
t = int(input())
if (s < 5) and not  t > 3:
    print("YES")
else:
    print("NO")

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(9, 9); (9, 10); (8, 5); (11, 6); (–11, 10); (–5, 9); (–10, 10); (4, 5); (8, 6).

Сколько было запусков, при которых программа напечатала «NO»?

Варианты ответов
  • 9
  • 0
  • 2
  • 1
  • 6
  • 5
  • 4
  • 3
  • 7
Вопрос 9

Что выведет следующий код? 

for i in range(5):
    print(i, end=" ")

Вопрос 10
Что напечатает на экране следующая программа?
i = 5
while i > 0:
    i -= 1
    if i == 2:
        break
    print(i, end=" ")
Вопрос 11

Какое значение будет иметь переменная total после выполнения цикла?

 

total = 0
for i in range(1, 6):
    total += i
Варианты ответов
  • 15
  • 10
  • 21
  • 5
Вопрос 12

 До каких пор работает цикл while?

Варианты ответов
  • пока условие не становится истинным
  • пока не произойдет экстренная остановка программы
  • пока условие не становится ложным
  • пока не достигнут лимит памяти
Вопрос 13
Каково основное назначение циклов в Python?
Варианты ответов
  • за отладку программы
  • за повторение определенной части кода несколько раз
  • за цикличное выделение памяти
  • за обработку Python-списков
Вопрос 14

Какой диапазон чисел генерирует range(2, 10, 2)?

Варианты ответов
  • 2, 4, 6, 8
  • 2, 4, 6, 8, 10
  • 0, 2, 4, 6, 8
  • 2, 3, 4, 5, 6, 7, 8, 9
Вопрос 15

Что будет выведено на экран в результате выполнения инструкции?

print('Гостиница 'Орбита', 3 звезды.')

Варианты ответов
  • ошибка
  • Гостиница 'Орбита' 3 звезды.
  • Гостиница Орбита 3 звезды
  • Гостиница 3 звезды
Вопрос 16

Определите, что будет напечатано в результате выполнения следующей  программы:

a = 6
b = 3
while (a!=5):
    a -= 1
    b += a
print(b)     
        

Варианты ответов
  • 8
  • -8
  • 0
  • ошибка
  • 5
  • 9
  • -5
Вопрос 17

Какой результат выведет программа на экран?

a = 1
b = 3
while (a!=5):
    a += 1
    b += a
print(b, b + a) 
                        

Варианты ответов
  • 17, 22
  • 17, 12
  • 22, 12
  • 12, 17
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт