Меню
Тесты
Тесты  /  Информатика  /  11 класс  /  11_7. Информатика 2023. Запись алгоритмов на языке программирования Паскаль

11_7. Информатика 2023. Запись алгоритмов на языке программирования Паскаль

Avatar
26.11.2023. Тест. Информатика, 11 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
11_7. Информатика. Запись алгоритмов на языке программирования Паскаль

Список вопросов теста

Вопрос 1

Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 268;
b := (a mod 100) * 10;
a := a div 100 + b * 10;

Варианты ответов
  • a = 6802, b = 680
  • a = 682, b = 680
  • a = 266, b = 246
  • a = 700, b = 20
Вопрос 2

Определите значение переменной c после выполнения следующего фрагмента программы, в котором a, b и с – переменные вещественного (действительного) типа:

a := 100;
b := 120;
b := a + b / 2;
if b < a / 2
  then 
c := b + a
  else c := b + a / 2;

Варианты ответов
  • 210
  • 185
  • 200
  • 220
Вопрос 3

Определите значение переменной P после выполнения следующего фрагмента программы:

P := 1; i := 4;
while i <= 9 do
  begin

    P := P * (i div 4);
    i := i + 1;
  end;

Варианты ответов
  • 4
  • 24
  • 1
  • 36
Вопрос 4

Определите значение переменной y, которое будет получено в результате выполнения следующей программы:

var n,  y: integer;
begin
  y := 0;
  for n := 6 downto 2 do
     begin
         y := y + 1;
         y :=y * 2;
     end;
end.

Вопрос 5

Определите, что будет напечатано в результате работы следующего фрагмента программы:

var k, s: integer;
begin
  s:=0;
  k:=1;
  while s < 30 do
      begin

          k:=k+3;
          s:=s+k;
      end;
  write(s);
end.

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт