Меню
Разработки
Разработки  /  Информатика  /  Уроки  /  9 класс  /  Что такое программирование. Знакомство с языком Паскаль. Алгоритм работы с величинами.

Что такое программирование. Знакомство с языком Паскаль. Алгоритм работы с величинами.

27.01.2021

Содержимое разработки

Предмет: Информатика

Класс 9

Тема: Что такое программирование. Знакомство с языком Паскаль. Алгоритм работы с величинами.

Тип урока: урок изучения нового материала

Цели урока:

1.Обучающая – познакомить учащихся со структурой программы и с правилами программирования, научить создавать простые программы на языке Pascal.

2.Развивающая - развитие логического и алгоритмического мышления школьников, приемов умственной деятельности, формирование и развитие функционального мышления учащихся, развитие познавательных потребностей учащихся, развитие навыков работы в среде программирования высокого уровня.

3.Воспитательная – воспитание информационной культуры учащихся, побудить интерес к изучению информатики, формирование творческого воображения и умения решать нестандартные задачи, научить находить нестандартные пути для решения задач.

Оборудование: компьютер, мультимедийный проектор, компьютерная презентация.


План урока:

  1. Организационный момент (2 мин)

  2. Актуализация опорных знаний(2 мин)

  3. Мотивация(2 мин)

  4. Целеполагание(2 мин)

  5. Объяснение материала (20мин)

  6. Практическое задание(10 мин)

  7. Диагностика (5 мин)

  8. Домашнее задание(1 мин)

  9. Рефлексия(1 мин)


  1. Организационный момент (2 мин)

  • Приветствие

  • Проверка присутствия всех учащихся

  • Сообщение учащимся даты, темы и плана урока


  1. Актуализация опорных знаний(2 мин) презентация


  1. Мотивация(2 мин) презентация


  1. Целеполагание(2 мин) Исходя из темы урока, обучающиеся формируют цели урока


  1. Объяснение материала (20мин) презентация

Среди современных языков программирования одним из самых популярных является язык Паскаль. Этот язык разработан в 1971 году и назван в честь Блеза Паскаля – французского ученого, изобретателя механической вычислительной машины.

Паскаль – это универсальный язык программирования, позволяющий решать самые разнообразные задачи обработки информации.

Команду алгоритма, записанную на языке программирования, принято называть оператором.

Программа на Паскале близка по своему виду к описанию алгоритма на Алгоритмическом языке. Давайте сравним алгоритм решения одной и той же задачи на алгоритмическом языке и на языке Паскаль. Задание 1. Учитель записывает на доске текст программ.

Очень похоже на перевод с русского языка на английский.

Программа на Паскале состоит из заголовка, описаний и операторов.

Учитель включает проекционный экран, появляется слайд следующего содержания:


Формат заголовка программы:

Program «имя программы»


Формат описания переменных:

Var «список однотипных переменных»: «тип»; …


Раздел операторов:

begin

«операторы»

end.


Операторы ввода данных с клавиатуры:

read («список ввода»),

readln(«список ввода»).


Операторы вывода на экран:

write(«список вывода»),

writeln(«список вывода»)


По каждому пункту учитель дает пояснения.


Далее мы с вами рассмотрим правила записи арифметических выражений.

(записывает на доске)

+ сложение

- вычитание

* умножение

/ деление


В отличие от математики, знак умножения опускать нельзя.


Нужно записывать 2*b, а не 2b, не х2 , а х*х или SQR(x).


Последовательность выполнения операций определяется по их приоритетам, круглые скобки также влияют на порядок действий.


Например:

4 1 3 2 (порядок действий)

А+(В-С)/(3+К)


  1. Практическое задание(10 мин)

-Ребятки, вы знаете, что сила тяжести существует везде, в том числе и в космосе. Что удерживает Луну на её орбите вокруг Земли? Сила тяжести. Что удерживает Землю на орбите вокруг Солнца? Сила тяжести. Что не позволяет галактикам разлетаться в разные стороны? Сила тяжести.

Давайте, вспомним, по какой формуле определяется сила тяжести

Вспомнили, предлагаю написать программу, которая позволит нам

найти силу тяжести, действующую на ученика массой 45 кг?


Структура программы следующая


Давайте, теперь попробуем написать программу

Program Сlass;

Var F,m,g: real;

Begin

Write ('m,g');

Read (m,g);

F:=m*g;

Write ('F=',F);

End.


Сейчас запишите в тетрадях на языке Паскаль следующие выражения:

a) A+D:C;

b) A2 + B3 – 14C;

c) 25(a2 –b2).

-Задача каждого из вас написать программу, которая будет находить плотность вещества. Один из вас напишет ее на языке Pascal, а другой на алгоритмическом языке, с помощью блок- схем.

Pascal


Алгоритм


Program Fer;

Var p,m,V: real;

Begin

Write ('m,V');

Read (m,V);

P:=m/V;

Write ('P=',P);

End.




  1. Диагностика (5 мин)

Проверка выполненного практического задания


  1. Домашнее задание(1 мин)

§8 - 11 читать, ответить на вопросы в конце параграфа устно


  1. Рефлексия(1 мин)

  • Что нового я узнал(а)?

  • Как я усвоил новый материал?

  • Где я могу это применить?

  • Хорошо ли я работал(а) на уроке?



-75%
Курсы повышения квалификации

Система работы с высокомотивированными и одаренными учащимися по учебному предмету

Продолжительность 72 часа
Документ: Удостоверение о повышении квалификации
4000 руб.
1000 руб.
Подробнее
Скачать разработку
Сохранить у себя:
Что такое программирование. Знакомство с языком Паскаль. Алгоритм работы с величинами. (191.32 KB)

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт